This page is a wiki. Please login or create an account to begin editing.


Mac Games Arcade free

Rating:
No votes yet
Category:
Perspective:
Year released:
Author:
Publisher:
Engine:
#1
[www].se [ftp].se [mirror].us [mirror].de
Mac_Games_Arcade.dmg (2.00 MB)
MD5: 425a4df78890ff74c93d6a89c3de5e26
For Mac OS X
#2
[www].se [ftp].se [mirror].us [mirror].de
MacGameStore.dmg (5.09 MB)
MD5: a21159e3fd526f4bcbaecf07596a2e9a
For Mac OS X
#3
[www].se [ftp].se [mirror].us [mirror].de
Mac_Game_Store_2.4.4_Webkit_537.7z (28.88 MB)
MD5: a94eb7c7e86f9ea69eab9fbbf0ded6f0
For Mac OS X
Emulation
Guides on emulating older games

Purchase and download games wihout the hassle of DMG's. Keep games up-to-date with automatic game updates. Finished a game? Delete it and send it back to the cloud. Download it again from the cloud any time you want.

Update 14.12.2020:

Added a link to a customized version of Mac Game Store 2.4.4 that still works fine on 10.5.8 Leopard by implementing a universal build of Leopard Webkit 537 that supports TLS 1.2. (compiled by thedoctor45).

Compatibility
Architecture: PPC

Comments

scott Praed's picture
by scott Praed - 2020, December 24 - 11:06pm

Thank you for your hard work for fixing this. The application works on power mac G4 1.25 Mirror door 2003 running mac os x 10.5.8 on Radeon 9000 pro 128 MB video card and 2GB of Ram.

thedoctor45's picture
by thedoctor45 - 2020, December 24 - 7:06pm

I've updated the archive with another version of sqlite3.0 taken from a more recent PPC build of Leopard Webkit.

Try redownloading the MGS app and let me know if it works.

PS: Looks like the store has a Holiday Sale special for the next few days and there are still a couple of 10.5 compatible games on there that might be worth buying.

scott Praed's picture
by scott Praed - 2020, December 20 - 10:11pm

Yes, I did replaced the file.

thedoctor45's picture
by thedoctor45 - 2020, December 20 - 5:29am

Weird that it's still showing the same problem. Are you sure you replaced the library?
On Intel 10.5.8 it works without any problems.
I guess I'll have to dig out my old PPC Mac and test it myself to pin down the cause of this issue.

scott Praed's picture
by scott Praed - 2020, December 19 - 10:00pm

Last login: Sat Dec 19 03:52:56 on ttys000
/games\ files/Mac\ Game\ Store.app/Contents/MacOS/Mac\ Game\ Store ; exit;
scott-praeds-power-mac-g4:~ scottpraed$ /games\ files/Mac\ Game\ Store.app/Contents/MacOS/Mac\ Game\ Store ; exit;
dyld: lazy symbol binding failed: Symbol not found: _sqlite3_open_v2
Referenced from: /games files/Mac Game Store.app/Contents/MacOS/../Frameworks/10.5/Security.framework/Versions/A/Security
Expected in: /usr/lib/libsqlite3.0.dylib

dyld: Symbol not found: _sqlite3_open_v2
Referenced from: /games files/Mac Game Store.app/Contents/MacOS/../Frameworks/10.5/Security.framework/Versions/A/Security
Expected in: /usr/lib/libsqlite3.0.dylib

Trace/BPT trap
logout

[Process completed]

The application also crashed. I also have the libsqlite 3.0.dylib in usr/lib of
my hard drive.

thedoctor45's picture
by thedoctor45 - 2020, December 19 - 5:12pm

Please post the terminal output here, otherwise I can't help.

scott Praed's picture
by scott Praed - 2020, December 19 - 10:03am

I found out I was using libsqlite 3.0.dylib. The folder usr/lib was invisible. I have application that will shows invisible folder. I download the file and put in my usr/lib and replace it. But the application crash on launched.

scott Praed's picture
by scott Praed - 2020, December 15 - 10:49pm

I am not running libsqlite 3.0.dylib in my system because the libsqlite 3.0.dylib in the mac game store application. The libsqlite 3.0.dylib not in anywhere in my computer. It makes sense why mac game store 2.4.4 crash on launch.

thedoctor45's picture
by thedoctor45 - 2020, December 15 - 4:31pm

Looks like you're using an incompatible version of libsqlite3.0.

https://www.mediafire.com/file/r6elj7wwqkpzzun/libsqlite3.0.dylib.zip/file

Try downloading this one instead and place it into the /usr/lib/ directory on your harddrive.
Be warned that the system needs this library to function properly so if you remove the old one while the system is running you will brick your OS X version and it will become unresponsive and refuse to boot.

You should make a backup of the original file just in case the new lib gives you any unexpected problems.

Then you should place the new lib on the desktop and try executing the command "sudo cp ~/Desktop/libsqlite3.0.dylib /usr/lib/libsqlite3.0.dylib" in terminal to replace it. Just don't remove the original without overwriting it.

scott Praed's picture
by scott Praed - 2020, December 15 - 9:26am

I have power mac G4 1.25 Ghz mirror door 2003 running mac os x 10.5.8. This PPC mac. I open the mac game store 2.4.4 will better zip. Then I open it but it crash again. I control click show the package contents. Then I click on mac game store in MacOS. Then paste what the terminal shows

Last login: Tue Dec 15 03:13:39 on ttys000
/Users/scottpraed/Desktop/Mac\ Game\ Store.app/Contents/MacOS/Mac\ Game\ Store ; exit;
scott-praeds-power-mac-g4:~ scottpraed$ /Users/scottpraed/Desktop/Mac\ Game\ Store.app/Contents/MacOS/Mac\ Game\ Store ; exit;
dyld: lazy symbol binding failed: Symbol not found: _sqlite3_open_v2
Referenced from: /Users/scottpraed/Desktop/Mac Game Store.app/Contents/MacOS/../Frameworks/10.5/Security.framework/Versions/A/Security
Expected in: /usr/lib/libsqlite3.0.dylib

dyld: Symbol not found: _sqlite3_open_v2
Referenced from: /Users/scottpraed/Desktop/Mac Game Store.app/Contents/MacOS/../Frameworks/10.5/Security.framework/Versions/A/Security
Expected in: /usr/lib/libsqlite3.0.dylib

Trace/BPT trap
logout

[Process completed]

Then mac game store crash in terminal.

thedoctor45's picture
by thedoctor45 - 2020, December 15 - 3:34am

Btw, make sure you use a proper app to extract the 7z archive - I recommend BetterZip.

thedoctor45's picture
by thedoctor45 - 2020, December 15 - 2:34am

Are you running Leopard on an Intel or PPC Mac? I haven't tested PPC support but it should work.

Also try dragging the Mac Game Store binary located in MGS.app/Contents/MacOS on a Terminal window and paste the output here.

scott Praed's picture
by scott Praed - 2020, December 15 - 2:17am

I tried custom version of mac game store 2.4.4 and it don't work. The application bounce on dock and crash.
I also repair the disk permission.

OpenSourceMac's picture
by OpenSourceMac - 2020, December 15 - 1:06am

It's AWESOME this still works.

thedoctor45's picture
by thedoctor45 - 2020, December 15 - 1:24am

I managed to bypass the TLS issue by bundling a universal build of Leopard WebKit v537 with the MGS app which means it should now work again on OS X Leopard (PPC & Intel).

scott Praed's picture
by scott Praed - 2020, September 23 - 2:53am

The macgamestore.dmg will not work on mac os x 10.5.8. I tried it. The application said this MacGameStore.com is currently unavailable. The mac Game Store is temporarily unavailable (secure Connection Failed) Please enjoy playing your currently installed Games and demos. I tried reset the application that also failed too. I also contracted mac game store support and They can't help me but they sent me emails. Here are mac game store support emails

Kurt (MacGameStore Support)
Aug 2, 2020, 4:16 AM PDT
We've recently updated the security on our server, so it now requires TLS 1.2 to connect. That means Mac OS X 10.10 and earlier are no longer supported.

brainic
Aug 1, 2020, 9:35 PM PDT
mac game store application server connection failed.
I running mac os x 10.5.8. I can't download or buy games through the application. 
I reset the application but it did not work. Can you tell me how I fix this ?
This email is a service from MacGameStore Support. Delivered by Zendesk | Privacy Policy
[3QPX5P-073M]
Reply | Reply to all | Forward | Print | Delete | Show original

  scott praed
Sun, Aug 2, 2020 at 3:18 PM

 
Kurt (MacGameStore Support)

Sun, Aug 2, 2020 at 4:46 PM
Reply-To: MacGameStore Support
To: brainic
Reply | Reply to all | Forward | Print | Delete | Show original
##- Please type your reply above this line -##
Your request (12384) has been updated. To add additional comments, reply to this email.

Kurt (MacGameStore Support)
Aug 2, 2020, 1:46 PM PDT
Yes, we recently brought our server more up to date on security, and versions of macOS prior to 10.11 don't have the required version of TLS. So older Macs aren't able to download files that require login. Possibly not any, at all, if the website and associated files aren't loading, either.

As for 32bit versus 64bit support, I think you may be thinking of Apple's recent changes to macOS beginning with macOS 10.15 Catalina. Catalina and Big Sur (macOS 11) can't launch 32bit apps, including older game apps. They can only launch 64bit apps.

It is interesting that you're using a PowerPC Mac and that Apple has just announced another chip transition from Intel to their own Apple SoCs, like the first transition from PowerPC to Intel back in 2006. The first Apple Silicon Macs will be released this fall. If you wait a little while to purchase your next Mac, you may be able to skip all 14 years of the Intel era, completely.

brainic
Aug 2, 2020, 12:19 PM PDT
the application said this.
Mac game store is temporarily unavailable ( secure connection failed).
Please enjoy playing your currently installed games and demos.
Can you confirm this. I need mac os x 10.10 or later. It needs 32 bit
Power PC and 32 bit intel has been drop and no longer support. Only
intel 64 bit is supported.

Kurt (MacGameStore Support)
Aug 2, 2020, 4:16 AM PDT
We've recently updated the security on our server, so it now requires TLS 1.2 to connect. That means Mac OS X 10.10 and earlier are no longer supported.

brainic
Aug 1, 2020, 9:35 PM PDT
mac game store application server connection failed.
I running mac os x 10.5.8. I can't download or buy games through the application. 
I reset the application but it did not work. Can you tell me how I fix this ?
  Kurt (MacGameStore Support)
Sun, Aug 2, 2020 at 7:16 AM

 
scott praed

Sun, Aug 2, 2020 at 3:18 PM
To: MacGameStore Support
Reply | Reply to all | Forward | Print | Delete | Show original
the application said this.

Mac game store is temporarily unavailable ( secure connection failed).
Please enjoy playing your currently installed games and demos.

Can you confirm this. I need mac os x 10.10 or later. It needs 32 bit
Power PC and 32 bit intel has been drop and no longer support. Only
intel 64 bit is supported.

Kurt (MacGameStore Support)
Aug 2, 2020, 1:46 PM PDT
Yes, we recently brought our server more up to date on security, and versions of macOS prior to 10.11 don't have the required version of TLS. So older Macs aren't able to download files that require login. Possibly not any, at all, if the website and associated files aren't loading, either.

As for 32bit versus 64bit support, I think you may be thinking of Apple's recent changes to macOS beginning with macOS 10.15 Catalina. Catalina and Big Sur (macOS 11) can't launch 32bit apps, including older game apps. They can only launch 64bit apps.

It is interesting that you're using a PowerPC Mac and that Apple has just announced another chip transition from Intel to their own Apple SoCs, like the first transition from PowerPC to Intel back in 2006. The first Apple Silicon Macs will be released this fall. If you wait a little while to purchase your next Mac, you may be able to skip all 14 years of the Intel era, completely.