This page is a wiki. Please login or create an account to begin editing.


Doomsday Engine Ports

Rating:
Your rating: None Average: 3 (6 votes)
Category:
Perspective:
Year released:
Author:


Publisher:
Engine:
Emulation
Guides on emulating older games

The Doomsday Engine is a greatly enhanced DOOM source port available for Windows, Mac OS X, Ubuntu and most other Unix platforms.
Doomsday supports many games including the classic first-person shooters DOOM, Heretic and Hexen. It aims to retain the original feel of the games yet leverage modern techniques and technologies, including hardware accelerated 3D graphics and client/server networking. A lot of emphasis is placed on good-looking graphics.

Notes:
Separate applications have been created for each game as standalone ports for your convenience, also many additional add-ons have been installed for maximum visual experience (see screenshots). Widescreen resolutions are supported. The games have been tested on Mac OS X 10.5.8 Intel & PPC machines.

Compatibility
Architecture: PPC x86 (Intel:Mac)

Comments

OpenSourceMac's picture
by OpenSourceMac - 2020, November 27 - 7:59am

So for anyone who wants to jump over anything after Tiger and skip to Linux or Windows, here is the link: https://dengine.net/

thedoctor45's picture
by thedoctor45 - 2020, November 27 - 4:30am

I am unable to upload files to the site for some reason (the uploads keep stalling) so I had to host them externally. Like the description says it's only been tested on 10.5.8 - it uses the latest Doomsday Engine that still supports PPC - I have no way of verifying functionality on 10.4 or lower.

OpenSourceMac's picture
by OpenSourceMac - 2020, November 27 - 2:40am

Thanks so much but my card is a 9000. Do you know where there downloads for Windows versions are? I checked and all I run into are these Mac versions. If you don't have time, will do some more looking on my own.

scott Praed's picture
by scott Praed - 2020, November 27 - 12:42am

I have doomsday engine 1.10 and 1.9.10. Both version for mac os x 10.4 and open GL 1.4. Do want me upload both version ? You will need open GL 1.4 card for both vesions. Both version don't work on Radeon 9000 but both work on Radeon 9800 or 9600. You said it don't work on mac os x 10.4. Did you Tried switching video cards ? What was the problem with doomsday engine 1.10 ?

MikeTomTom's picture
by MikeTomTom - 2020, November 26 - 11:01pm

DOES NOT WORK in 10.4 (PPC).

The creator of this page appears to have uploaded a version[s] of the Doomsday Engine to his own mediafire account and has not credited the Doomsday Engine authors at degine.net for their involvement in this project.

Go here for a version of the Doomsday Engine for PPC Mac OS 10.4 you will need to DL version 1.10

I'm not sure that this page in it's current form should be here, as the Doomsday site has their own active community and support pages etc.

OpenSourceMac's picture
by OpenSourceMac - 2020, November 26 - 11:45am

DOES NOT WORK in 10.4 (PPC).