This page is a wiki. Please login or create an account to begin editing.

2 posts / 0 new
Last post
Jatoba's picture
Joined: 2018 Apr 16
Mac-on-Mac on Mac mini G4?

(lol at the title)

So, surely many of you guys have heard of the non-G5 X11-based Mac-OS-X-Panther-centric port of Mac-on-Linux called Mac-on-Mac, a program that allows the creation of Mac OS and Mac OS X virtual machines (and, to little success, also of some specific GNU/Linux distributions or specific versions, allegedly). It's currently distributed in SourceForge.

I was trying to get that thing to work under Panther (Server version), both 10.3.9 and 10.3.4, and tried to first create a OS X Puma virtual machine, for starters. The configuration menu is very simple, and I followed all the steps that were archived from the creator's website, but after authentication and after making sure X11 was closed before starting MoM up, no virtual machine window pops up. xterm opens and executes just fine, the progress bar in MoM goes all the way to the end, but nothing comes up.

I followed every instruction I could find in the archived official page and also in the SourceForge page, but to no avail.

There's supposedly a log file generated somewhere (/Users/your_name/Mac-on-Mac/VM[1..4]/MomX.log), but the MoM directory is not there. Not sure where to look for it, or if it has even been generated.

So, in short, has anyone here ever used Mac-on-Mac on the Mac mini G4 successfully, under Panther? If so, any help or directions is appreciated. Smile


Jatoba's picture
Joined: 2018 Apr 16

Alright, guys, I got it. Let me share the knowledge in case anyone else out there one day also wishes to use Mac-on-Mac on any of the 4 Mac mini G4 models...

The issue I had was the following, somewhat surprisingly:

I was trying to get that thing to work under Panther (Server version), both 10.3.9 and 10.3.4 [...]

It does not seem like the Server versions are compatible at all. The solution was to use the CLIENT version of Panther. In this case, I tested specifically v10.3.7, which is what the earliest Mac mini G4 models came pre-installed with.

All 4 Mac mini G4 models can install that version of Panther, although the 2 "silent upgrade" models (like mine) require a little fix on the install image. More info on that, as well as the install image itself, can be found here:

Hooray! Cool stuff.™

Edit: In case someone ends up here from googling, here are a few notes about Mac-on-Mac usage:

- For any path specified (disc image, for instance) within Mac-on-Mac, it MUST NOT HAVE spaces anywhere. I had to rename even a drive partition to run it properly;

- Likewise, it seems a few special characters on the path cause Mac-on-Mac to fail. Parenthesis, that is, the "(" and ")" characters is one set of characters that also seemed to cause problems. Some other characters are fine, however, like dashes ("-"), underscores ("_") and periods (".");

- The image types used HAVE to be ".iso", ".cdr" or even ".toast". You cannot use ".dmg". It seems to be all about the file headers themselves, and not the extensions, so renaming files won't break nor fix things;

- I could boot up all versions of 10.1 Puma and 10.2 Jaguar, both client and server. For Panther, I couldn't boot anything past 10.3(.0), although both client and server worked. However, 10.0 Cheetah and earlier, such as Rhapsody, don't work at all. Tiger and Leopard are also expected not to work. I also tried Debian Jessie and a recent version of Gentoo, but no luck. Supposedly, the original Mac OS works, but I have yet to try it out;

- Closing and reopening Mac-on-Mac sometimes solves issues (such as Mac-on-Mac not starting up VMs suddenly). Always make sure X11 is closed in advance, as well.

Oh, also, everything I did was on Mac-on-Mac version 0.2, the pre-compiled binary that was officially distributed. No earlier, no later.