This page is a wiki. Please login or create an account to begin editing.


4 posts / 0 new
Last post
borrego93010's picture
Offline
Joined: 2020 Oct 26
.DSK Files and Diskcopy 4.2 & 6

Hi Guys:

Just getting started with Macintosh (Real Hardware) and I have gotten stumped recently with .dsk files. I finally got stuff it loaded on my Mac Powerbook 160 and had Diskcopy 6.? running. I could mount the .dsk files and work with them. Now for some reason the computer does not see any of the .dsk files in either version of Diskcopy. I can still use stuffit to expand .sit files and that works fine as long as there isn't a .dsk file stuck inside of it. I tried filetyper and it's pretty much greek to me on how to set the file type correctly (They are showing up sometimes as text files). I tried loading Diskcopy 4.2 and it doesn't see the .dsk files either.

Anybody that can point me in the right direction will make this longtime Windows user's migrane go away lol!

Thanks,

Borrego93010

Comments

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

Disk Copy 6 should be version 6.1.2 or higher (version 6.3.3 is the most common official release).

Try; dragging the .dsk icon over onto the Disk Copy 6 icon, when the DC6 icon darkens, let the mouse button go. This should force it to attempt to mount the disk. In the case of .dsk image files it usually will, unless there is something not right with the image file.

You can also launch Disk Copy 6 and drag and drop the .dsk file into the running window of DC6, this should also work.

The Disk Copy 6 application's icon can be of the actual icon or an alias (shortcut) file placed in some convenient location, such as on the desktop.

Most (but not all) .dsk image files found in most old Mac archives were created using DiskDup+ or DiskDup Pro.

These often include in with their download, a FileTyper droplet app that corrects the generic icons of .dsk images which cause that issue you are getting. I know that version 2.9.2 on that page does include the FileTyper app, I assume others there may also carry this app.

borrego93010's picture
Offline
Joined: 2020 Oct 26

Thanks! That worked (dragging the .dsk file over the Diskcopy Icon). Unfortunately my screen that was flickering and sorta useable has now decided to die completely (All grey). The machine still boots and shuts down but I have yet to get the screen to come back to life Sad I have another Powerbook 150 but the hard drive is making some interesting sounds (Display is great though! lol). I am going to look into loading an emulator on my laptop and putting the actual hardware into storage for a bit until I have time to tinker.

adespoton's picture
Offline
Joined: 2015 Feb 15

Sometime in the 90s, for disk mounting purposes, I switched to Aladdin ShrinkWrap. It can mount DiskCopy 4 and 6 images as well as DiskDup images and its own compressed SHK format (not the same as the old Apple SHK images for ProDOS).