This page is a wiki. Please login or create an account to begin editing.

10 posts / 0 new
Last post
TheComputerKid's picture
Joined: 2011 Oct 18
ATi Radeon 9200 (OpenGL?) problems

I finally upgraded my graphics card. I went to plug in my Apple Cinema Display, and the card worked. I went to play Marble Blast Gold, and after it loads a level, it crashes. I found out that I need to update the drivers. I installed every update I could find. After that, I relaunched the game, still had the same problem.

Crash Log:

Date/Time: 2001-01-11 23:46:51 -0600
OS Version: 10.2.8 (Build 6R73)
Host: Jeremy-Maganas-Computer.local.

Command: MarbleBlast Gold
PID: 362

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x0000001c

Thread 0 Crashed:
#0 0x001553b8 in _ZN10SceneStateD4Ev
#1 0x001553c4 in _ZN10SceneStateD4Ev
#2 0x000d0af8 in _Z15GameRenderWorldv
#3 0x000c5b48 in _ZN10GameTSCtrl11renderWorldERK5RectI
#4 0x001141ec in _ZN9GuiTSCtrl8onRenderE7Point2IRK5RectI
#5 0x000c5eb0 in _ZN10GameTSCtrl8onRenderE7Point2IRK5RectI
#6 0x000f0a34 in _ZN9GuiCanvas11renderFrameEb
#7 0x000bf2a0 in _ZN8DemoGame16processTimeEventEP9TimeEvent
#8 0x001a8af0 in _ZN11TimeManager7processEv
#9 0x000bdfa4 in _ZN8DemoGame4mainEiPPKc
#10 0x001a85e8 in _Z10DoRAELLoopP16__EventLoopTimerPv
#11 0x90163230 in __CFRunLoopDoTimer
#12 0x90148d28 in __CFRunLoopRun
#13 0x90180f58 in CFRunLoopRunSpecific
#14 0x969a3b70 in RunCurrentEventLoopInMode
#15 0x969b3a78 in ReceiveNextEventCommon
#16 0x969f2b5c in _AcquireNextEvent
#17 0x96ab4cf8 in RunApplicationEventLoop
#18 0x001a8a74 in main
#19 0x000095b0 in _start (crt.c:267)
#20 0x00009430 in start

Thread 1:
#0 0x90006a28 in clock_sleep_trap
#1 0x9000672c in nanosleep
#2 0x9003e248 in usleep
#3 0x0021587c in _ZN8NetAsync3runEv
#4 0x00215ae4 in _Z15StartThreadFuncPv
#5 0x90020c28 in _pthread_body

Thread 2:
#0 0x90073ba8 in mach_msg_trap
#1 0x90005ed0 in mach_msg
#2 0x901489f0 in __CFRunLoopRun
#3 0x90180f58 in CFRunLoopRunSpecific
#4 0x9465c1c0 in _ZN10HALRunLoop9OwnThreadEPv
#5 0x946511b0 in _ZN9CAPThread5EntryEPS_
#6 0x90020c28 in _pthread_body

PPC Thread State:
srr0: 0x001553b8 srr1: 0x0000f030 vrsave: 0x00000000
xer: 0x00000000 lr: 0x001553c4 ctr: 0x9005e1f8 mq: 0x00000000
r0: 0x00000005 r1: 0xbfffece0 r2: 0x0015881c r3: 0x0312fb80
r4: 0x00000000 r5: 0x00000004 r6: 0x022997e0 r7: 0x00000018
r8: 0x00458010 r9: 0xa0001048 r10: 0x02cee010 r11: 0xa00044b0
r12: 0x9005e1f8 r13: 0x00000000 r14: 0x00000000 r15: 0x00000001
r16: 0x00000000 r17: 0x00000001 r18: 0x03153d18 r19: 0x03153d24
r20: 0x03153d58 r21: 0x0094ba04 r22: 0xbfffee70 r23: 0x03153d24
r24: 0x03153d30 r25: 0x03153d48 r26: 0x03153d30 r27: 0x03153d48
r28: 0x03153d3c r29: 0x03153d00 r30: 0x00000001 r31: 0x03153d3c

Does anyone have a solution?


bertyboy's picture
Joined: 2009 Jun 14

tried reducing colors before starting the game ?

TheComputerKid's picture
Joined: 2011 Oct 18

I tried every in-game video settings combinations and it still doesn't work. Is there a OpenGL Tester for Mac?

eastone's picture
Joined: 2009 Aug 12

I have the same problem with my G3 B&W and GeForce FX 5200 PCI. It works perfect in 2D but crashes when trying to use OpenGL. I already ordered Radeon 9200 PCI and i will check how it works.

TheComputerKid's picture
Joined: 2011 Oct 18

Well, together, lets find out the solution!
BTW, it's TGI-Friday!

8bitdad's picture
Joined: 2010 Feb 11

I have a 9200 PCI in a B&W G3. There are artifacts, but this might be due to the G4 upgrade.
It worked just peachy in my Beige G3, under OS 9.

scott Praed's picture
Joined: 2010 Oct 30

There is website might help you.
click on video and go down to mac radeon 9200 pci game tests/notes and hack to enable quartz extreme on pci radeon.
The website tell you how to hack your radeon card and enable quartz extreme on radeon 9200 pci card.
it works in 10.3 and 10.4 and might work in 10.2

TheComputerKid's picture
Joined: 2011 Oct 18

That might work.

eastone's picture
Joined: 2009 Aug 12

I have got my Radeon 9200 PCI yesterday and.... no any problems with Marble Blast Gold.

TheComputerKid's picture
Joined: 2011 Oct 18

Well, what's wrong with mine?