This page is a wiki. Please login or create an account to begin editing.


The Tower Of Silka

Rating:
Your rating: None Average: 5 (2 votes)
Category:
Perspective:
Year released:
Author:
Publisher:
Engine:
#1
[www].se [ftp].se [mirror].us
Tower_Of_Silka_Disk_1.img (1.41 MB)
For System 6.x - Mac OS 9
#2
[www].se [ftp].se [mirror].us
Tower_Of_Silka_Disk_2.img (1.41 MB)
For System 6.x - Mac OS 9
#3
[www].se [ftp].se [mirror].us
Silka_Disks-DC4.2.sit (2.61 MB)
For System 6.x - Mac OS 9
#4
[www].se [ftp].se [mirror].us
Silka_preinstalled.sit (3.17 MB)
For System 6.x - Mac OS 9
Emulation
This game works with: Mini vMac Mini vMac II

This is a dungeon crawler game released in Japan. The installer doesn't work when using Disk Copy to mount the image, a physical floppy disk is needed.

A pre installed game folder is included for convenience. On first boot you also need the serial number written on the instruction sheet (30700482)

DL #3 is a StuffIt 4 archive containing the two disk images converted to Disk Copy 4.2 format with Finder artefacts from 2006 removed.

Compatibility
Architecture: 68k

Requires HyperCard 2.2 or later to run.

KanjiTalk or a Japanese Language Kit supported for your Mac OS is recommended for Japanese fonts.

Comments

Jatoba's picture
by Jatoba - 2019, September 29 - 1:38pm

A quirky-looking RPG from Japan? It looks like as if it took some inspiration from Madou Monogatari! (Of Puyo Puyo fame, which more may be familiar with.)

And I'm a HUGE Madou fan. So I definitely will check this out. No idea how this one slipped under my radar before!

Many thanks to baku for uploading it!

baku's picture
by baku - 2018, December 26 - 2:50am

I'm guessing you may not have japanese fonts installed to even read the error message, but if you do, take a picture and I'll try to diagnose

mrdav's picture
by mrdav - 2018, December 14 - 7:32am

The installer does not work for me even when I use physical floppy disks on my 68040 LC630 running SSW 7.5. I can't work out why because the error message is in Japanese. Presumably my Mac is not old enough.