This page is a wiki. Please login or create an account to begin editing.


Star Mission

Rating:
No votes yet
Category:
Perspective:
Year released:
Author:
Publisher:
Engine:
Download star_mission.cdr_.sit (285.96 MB)
For System 7.0 - 7.6 - Mac OS 9
Emulation
This game works with: SheepShaver, Basilisk II,

Some lightyears away, in one of the off convenient asteroids swarms, twelve labyrinths of "Far Down Under" awaits the player. A multimedial challenge for each gamer, including 3D graphics and 3D animations.

External link
Download from Mega.Co.Nz

Other references of this game refer to "Space World" or "Far Down Under".

Amazon.de Buy Link: Star Mission [Gebundene Ausgabe]

See also: The Legacy: Star Mission

Compatibility
Architecture: 68k PPC

Hybrid CD for PC & Mac.

In the folder "APPLE", locate the application "Start" to run the game.

System requirements Mac:
68040, Mac OS 7.1, 2x CD-ROM

System requirements PC:
i486, 8 MB RAM, 2x CD-ROM, Windows 3.1+

Comments

by 24bit - 2011, December 4 - 7:44pm

Same for me as SwedeBear posted.
E5700 Hacki 64bit with SS D8.6 seems to work fine, as the CD is mounted via SS GUI.
I might check with Windows/Linux and my new project a AMD Hacki, if someone wants to know.

IIGS_User's picture
by IIGS_User - 2011, December 4 - 6:36pm

Thanks, very interesting report. Smile

by SwedeBear - 2011, December 4 - 2:10pm

I get this behaviour on SS with Mac OS 7.6 and QT 2. When I choose 'English' as preferred language the game crashes and takes SS with it. Running this under OS 9.0.4 I can start the actual game but no videos. The appear to be much more stable then. Oh, and I mount the image with Disk Utility or Virtual DVD-ROM/CD Utility within SS.

Edit: OK. Mounted the locked image as a volume to SS by adding it in the prefs. Started the game this time w choosing 'German' as preferred language. Made a few moves and then exited. Restarted the game and choosed 'English' and no problems!

Edit: Replaced 'xxx 7' by 'Mac OS 7' - IIGS User

IIGS_User's picture
by IIGS_User - 2011, December 4 - 9:32am

My Sheep configuration refuses to mount this, with resulting in unexpected quit of Sheep.
Someone please check with Sheepshaver, too.