This page is a wiki. Please login or create an account to begin editing.


SimCity Classic 2.0 Updater

Rating:
Your rating: None Average: 4 (1 vote)
Category:
Perspective:
Year released:
Author:
Publisher:
Engine:
#1
[www].se [ftp].se [mirror].us
simcity_Classic_2.0_updater.sit (1.47 MB)
For System 7.0 - 7.6 - Mac OS 9
#2
[www].se [ftp].se [mirror].us
new_sim_city_classic.sit (1.19 MB)
For System 7.0 - 7.6 - Mac OS 9
Emulation
This game works with: Mini vMac II

SimCity Classic Updater ReadMe:

This program will update SimCity Classic versions 1.4 and 1.4c to version 1.5 not 2.0.

What's Fixed -
A few minor simulation bugs
!!!SimCity Classic now works in 256 colors!!! - This is the primary reason for this update. SimCity Classic will now work on PowerMacintosh and Quadra machines that could not run in 16 colors that SimCity 1.4 required.
Quicktime support - Included are two quicktime music files that will play if in the same folder as SimCity Classic. Included on the deluxe SimCity Classic CD are two animated introduction files. Size prohibits redistributing them in this update package.
Speed - SimCity Classic now has Ultra Fast speed, this should run amazingly fast on powerful machines.

In order to complete the update of SimCity Classic, you'll need to copy the Scenarios folder and two SONG files from this folder into the same folder as SimCity Classic. To hear the music files, you will need to have QuickTime version 2.5 or newer installed as well.

SimCity Classic 1.5 may run slower on non Quadra and PowerMacintosh machines. For this reason, we recommend not updating SimCity Classic on older machines. I edit this because it not 2.0 but 1.5.

Simcity Classic Readme!

SimCity Classic® Last Minute Information

Please Read This!

Quicktime™ 2.5
----
SimCity Classic® requires Quicktime version 2.5 to play music and the startup animation correctly. We've included Apple's Quicktime 2.5 Install on this CD-ROM. To install it, launch the Install Quicktime™ application in the Quicktime™ Installer folder.
If you don't have a compatible version of Quicktime installed on your system, you will not get music, sound, or the intro animation. All other aspects of SimCity Classic will run just fine.

Installing SimCity Classic to run from your hard disk
----
For added speed, you may wish to copy SimCity Classic to your hard disk, rather than run it from CD-ROM. The easiest way to do this is to drag the SimCity Classic® CD-ROM icon on your desktop to the location on your system where you wish to copy SimCity Classic. After copying the files and installing Quicktime 2.5 (if neccessary), you can drag the Quicktime™ 2.5 Installer folder in the trash. Additionally, if you're really short on hard disk space and don't need to watch the intro each time you launch SimCity Classic, you can throw away the item named movie as well.

Loading PC Cities and Saving Mac Cities for the PC
----
Cities created or saved on PC's can be loaded into the Mac as long as they have the .CTY extension. Note that if you try to load a non-city with a .CTY extension, we're not responsible for the possible corruption of your personal space-time continuum (or your Mac, for that matter).
To save a city from the Mac for use on a PC, you need to use the Export PC Readable option from the File menu. Ifyou use the normal Save or Save As functions and save the city with a .CTY extension, the PC versions of SimCity will see the file, but will most likely crash if you try to load it.

Contacting Maxis
----
Need to get a hold of technical support? Have a burning question about life, the universe, and SimCity? Want to know about what's coming up? Here's how to get in contact with those diligent minions of technical support:

Maxis
2121 N. California Blvd. Suite 600
Walnut Creek, California
94596

Tech Support Phone - 1-510-927-3905
Tech Support FAX - 1-510-927-3736
Tech Support BBS - 1-510-927-3910

On the World Wide Web, point your browser to http://www.maxis.com for all kinds of hints, tips, and free stuff!

System requirements for updater application.
This program will update SimCity Classic versions 1.4 and 1.4c to version 1.5 not 2.0.

SimCity Classic for Quadra computers and Power Macintosh or better in 256 colors.
Apple Quadra in Mac OS 7.0.1 to Mac OS 8.1 or Power Macintosh in Mac OS 7 to Mac OS 9.2.2 and also Classic environment of Mac OS X 10.4.11 but not Mac OS X native.

First download is SimCity Classic 2.0 updater. I use StuffIt lite 3.6 but updater doesn't work in Mini vMac but works in mini vMac II in 256 colors. Mini vMac doesn't work because it needs more memory to run the updater.
2nd download is new SimCity Classic. This is version 1.5. I already updated to the newer version. I use StuffIt lite 3.6 from mac os 9.2.2 to make. This doesn't work in Mini vMac but works in Mini vMac II in 256 colors. Mini vMac said need more memory to run updater and new SimCity Classic said the same thing.

Compatibility
Architecture: 68k

68k and mini vmac II in 256 colors. I tested in mini vmac IIx and updater works. It might work on any mini vmac II in 256 colors.

Comments

scott Praed's picture
by scott Praed - 2018, October 8 - 10:54pm

I am sorry the 1st download did not work for you but I am glad the 2nd download work. That is why I upload the latest version from my power mac G4 1.25 Gz mirror door 2003 if anybody has problem with updater.

Good point you made. If there is newer 2.0 patch somewhere out there. Do anybody have newer simcity 2.0 updater? I tried updater on min vmac II and power mac G4 1.25 G4 mirror door 2003 and updater didn't update to 2.0 on both computers.

I think of upgrade for power mac 6100/66 is processor card upgrade from sonnet g3 266 hz but sonnet has did away all processor card upgrade. But you should look at ebay for sonnet G3 266 hz. I think that card will work on power mac 6100/66. I use have power mac 6100/60 and I upgrade the processor to sonnet G3 266 hz.

Bolkonskij's picture
by Bolkonskij - 2018, October 8 - 9:51am

Thanks everyone for quickly fixing this one! I don't have a OSX machine at hand right now, so you guys really helped me out Smile ... however, here is my experience trying to update 1.4 on an actual PowerMac 6100/66. The updater (1st download) won't update the game, throwing an error about a - supposedly - altered resource 302. (I looked it up, it's the options menu in the game... couldn't see any obvious changes).

I then downloaded the second file and just copy & pasted it over. Works now but ... boy, this is slow even on a 2nd generation PowerPC Mac! Even though I assigned it comfortable 12MB of RAM and got Quicktime > 2.5 installed, it takes a long time to generate the landscape and the music plays very choppy. (Sim City 2000 runs very well on that machine btw - even with huge cities). Must be an awful amount of old 68k instructions to emulate ...

The one thing I didn't get ... this one here updates to v1.5, although the page states 2.0 (and so does the name of the updater). Now is this the final patch or do we have a real 2.0 patch for PPC somewhere out there?

scott Praed's picture
by scott Praed - 2018, October 8 - 1:14am

I upload again. Simcity classic 2.0 updater and new sim city classic in stuffit lite 3.6. stuffit lite 3.6 it works in minimac. When update version 1.5 it will work in 256 colors only not in 16 colors. Use old version 1.4 in minivmac in 2 color or b/w and use old version 1.4c in 16 colors on minivmac.
It also said on read me file SimCity Classic 1.5 may run slower on non Quadra and PowerMacintosh machines. For this reason, we recommend not updating SimCity Classic on older machines. I confirm simcity classic 2.0 updaters and new sim city classic don't work on mini vmac because needs more memory but it does works on mini vmac II in 256 colors but slow.

MikeTomTom's picture
by MikeTomTom - 2018, October 7 - 9:46pm

Scott, I had just sent up replacements a few minutes before yours arrived. We may as well keep the one's I put up as they are compatible with extracting on 68000 Mac Plus's etc and Mini vMac.

StuffIt 6.0 is too new for Mini vMac or Mac Plus, SE etc.

[Edit]: Scott: I removed my uploads. Your StuffIt 6 uploads will be OK as is. Looks like these updaters require higher CPU, such as 68020 or newer and SSW 7.x and later. I was able to use StuffIt Expander 5.5 to extract your uploads OK.

scott Praed's picture
by scott Praed - 2018, October 7 - 9:41pm

I use drop stuffit 6.0 on sim city updater and new sim city to make archives.

MikeTomTom's picture
by MikeTomTom - 2018, October 7 - 9:10pm

This upload seems like a victim to OSX ... resource fork gone

The resource forks are there, only in a Mac OS X zip container. They require unzipping on a Mac OS X system to reconstitute.

I've repackaged as ".sit" and added them to the page, they'll be as intended now when extracted on classic Mac OS's.

Duality's picture
by Duality - 2018, October 7 - 8:34pm

There's a few sites out there that have a Stuffit version, that should have the resource forks. The one on Mac GUI should be solid, but I can't verify that right now.

Bolkonskij's picture
by Bolkonskij - 2018, October 7 - 5:02pm

This upload seems like a victim to OSX ... resource fork gone, files not recognized on classic Mac OS here. Any chance for a reupload?

IIGS_User's picture
by IIGS_User - 2017, June 1 - 4:50pm

I use NativeChecker to test this issue.

Thanks to Apple who asked the manufacturer to implement 68k code into the PowerPC processor line,
68k applications work fine (tho´: slower) on PowerPC equipped machines.
This Compatibility field indicates the real architecture of the game.

scott Praed's picture
by scott Praed - 2017, May 31 - 5:48pm

I check the updater with I love native! pro 3.1.1. It said the application is 68k only but will work on Power PC.

IIGS_User's picture
by IIGS_User - 2017, May 31 - 5:18pm

There is still an issue in the architecture area, when the editing pages.
If you click an architecture, another one is selected. No idea, why.

scott Praed's picture
by scott Praed - 2017, May 30 - 7:13pm

No, The updater is not Mac OS X native. The updater is classic environment compatibility.
The updater application require this system requirement

Apple Quadra running Mac OS 7.0.1 to Mac OS 8.1 or Power Macintosh running Mac OS 7 to Mac OS 9.2.2. Also run in Classic environment of Mac OS X 10.4.11 but not in Mac OS X native.

IIGS_User's picture
by IIGS_User - 2017, May 30 - 5:01pm

"PPC (Carbonized)", this is Mac OS X native, without requiring Classic Environment?