This page is a wiki. Please login or create an account to begin editing.


Shogo: Mobile Armor Division

Rating:
Your rating: None Average: 4.8 (13 votes)
Category:
Perspective:
Year released:
Author:
Publisher:
Engine:
#1
[www].se [ftp].se [mirror].us
Shogo_Installer_English.sit (244.59 MB)
For Mac OS 8.5 - 8.6 - Mac OS 9
#2
[www].se [ftp].se [mirror].us
Shogo_MAD.toast_.sit (494.38 MB)
For Mac OS 8.5 - 8.6 - Mac OS 9
Emulation
Guides on emulating older games

Shogo: Mobile Armor Division is a first person shooter video game released by Monolith Productions in 1998.

It was the first game to utilize Monolith's flagship Lithtech engine. It has heavy influences from Japanese anime, particularly Patlabor, Appleseed, and the various Gundam series. The game allows the player to pilot a large mech, as well as perform missions on foot.

Compatibility
Architecture: PPC

System Requirements: Mac OS 8.5, G3 @ 233 MHz CPU, 96 MB RAM, 80 MB disk space.

Comments

SkyCapt's picture
by SkyCapt - 2019, May 12 - 2:34pm

What's the diffs among the two dLs? ?
Is there a gfx card requirement? oh, old comment sez there is a soft render option.

themacmeister's picture
by themacmeister - 2015, September 13 - 3:05am
4

This game is on GOG.com for Windows only Sad

http://www.gog.com/game/shogo_mobile_armor_division

Looks better on Windows tho...

Ookami's picture
by Ookami - 2013, December 6 - 3:21pm
5

nice works perfectly on my indigo G3 burned to a disk on windows 7 and installed on os 9.22

MadMac's picture
by MadMac - 2010, July 26 - 10:52am

This game really rocks. I have some sync problems using high detail OpenGL too, but nothing significant.

bramcrack3r's picture
by bramcrack3r - 2009, September 4 - 10:07pm
5

THIS GAME ROCKS, THANK YOU!

j_damage•69's picture
by j_damage•69 - 2009, August 13 - 12:15pm

Got it to run, only see very minor graphical issues. See how it plays! Hmm is there anyway to stop the pausing in the game or is it just the engine? I run it on 16 bit OpenGL 1024x768 screen mode.

j_damage•69's picture
by j_damage•69 - 2009, August 13 - 8:14am

Haven't got it to run at all.. The file "SW-Renderer.out" appears to be missing! The app doesn't launch either. No updates, yes thats a big let down. I first saw the Demo version on pure-mac.com and they usually supply the updates for you. : /

MacWise's picture
by MacWise - 2009, August 13 - 7:39am

It installed without problems on my machine, but it has serious display problems with my Radeon card. The models look all weird unless I chose software rendering. It also quitted on me after one hour of playing--and over 15 minutes after my last save. It seems there was never an update released for the Mac.

j_damage•69's picture
by j_damage•69 - 2009, August 13 - 7:32am

Ok, be sure to use a newish mac with classic installed, before using these kinda installers. I got disk and system errors when trying to install and copy this to my old imac g3 from a burt CD. It's supposedly that my slot-loading CD ROM drive is damage in a way, needs replacing anyway.