This page is a wiki. Please login or create an account to begin editing.


Candy Crisis

Rating:
Your rating: None Average: 4.8 (9 votes)
Category:
Perspective:
Year released:
Author:
Publisher:
Engine:
Download candycrisis_1_0.zip (7.25 MB)
For System 7.0 - 7.6 - Mac OS X
Download candycrisis_1_2.zip (7.50 MB)
For System 7.0 - 7.6 - Mac OS X
Purchase
This game is still available from its publisher
Emulation
Guides on emulating older games

"Candy Crisis is an exciting combination of pure action and puzzle gaming! The game features twelve unique stages, complete with its own character and individual technique. Also, you can pair off against a friend, and even specify a handicap so that both players are evenly matched. And if you don't want to play against an opponent, Solitaire Crisis mode allows you to practice without having to compete against an opponent. A tutorial is included with the game as well, so even puzzle novices can become Candy Crisis champions in no time." --candycrisis.sourceforge.net

See also: PuyoPuyo, Skittles, Qwirks

Read more about the Puyo Puyo series of games on which this game is based at Wikipedia.org.

Compatibility
Architecture: PPC

Version 1.0 will work on Mac OS 7, but is not OS X native. Version 1.2 requires 8.6 or later and WILL run native in OS X.

Comments

by Brian McInnis - 2015, March 6 - 11:10pm
4

I downloaded version 1.2 on my Yosemite-running computer. A message tells me opening the disk image may make the computer less secure, or cause other problems. Does anyone know if there's any actual danger here?

Denus's picture
by Denus - 2014, May 29 - 5:03pm
5

From the author: Candy Crisis is free!
You do not need to purchase a registration code to play the game. Just use the following information to register:

User Name: Everybody
Code: WPTV-CRHV

Oh yeah!!!

someonebitmaleg's picture
by someonebitmaleg - 2011, April 13 - 3:13am

The 1.0 download will not run native in OS X, and should not be marked as such. Downloads cannot be marked separately, but I at least changed the Compatibility notes.

themacmeister's picture
by themacmeister - 2011, April 13 - 1:44am

Confirmed working on Intel i3 10.6.7!!! Amazing!

Download the OSX version for that :-/