This page is a wiki. Please login or create an account to begin editing.


3D Spades Deluxe

Rating:
Your rating: None Average: 4.7 (3 votes)
Category:
Perspective:
Year released:
Author:
Publisher:
Engine:
#1
[www].se [ftp].se [mirror].us
3DSpadesDeluxe33.dmg (15.64 MB)
For Mac OS 8 - 8.1 - Mac OS X
#2
[www].se [ftp].se [mirror].us
3DSpadesDeluxe33.zip (15.66 MB)
For Mac OS 8 - 8.1 - Mac OS X
#3
[www].se [ftp].se [mirror].us
3D_Spades_Deluxe_321.sit (28.71 MB)
For Mac OS 8 - 8.1 - Mac OS X
#4
[www].se [ftp].se [mirror].us
3d-spades-deluxe-classic.sit (8.07 MB)
For Mac OS 8 - 8.1 - Mac OS X
Emulation
This game works with: SheepShaver,

Classic shareware card game of Spades from the now discontinued publisher, Freeverse.

Top DL: The official Freeverse dmg image of 3D Spades Deluxe 3.3 from 2004.

2nd DL: A zipped .iso image conversion of the above .dmg as a more universally accessible file for other OS's. If extracting this under a native Mac OS 8.6 - 9.2.2, use MacZip to extract and the Virtual CD/DVD Utility to mount the .iso image.
MD5 checksum & filename: 0797ca12e912f145fd3544c8aa9adcbe *3DSpadesDeluxe33.zip

3rd DL: 3D Spades Deluxe 3.2.1 from 2003.

4th DL: 3D Spades Deluxe 2.2 from 2000. Classic Mac OS 8.1 or later only.
MD5 checksum & filename: 718eef785ec0da0c5eba9630f5a1c1da *3d-spades-deluxe-classic.sit

To register v. 3.3 or 3.2.1 do the following:

1) Set the date on your Mac to 3 September 2004
2) Enter S/N Name: Santa Claus and SN: S970-5000-1800-0804-U276
3) Register
4) You can now restore the date on your Mac

To register v. 2.2, use SN: 19304. You can enter any name.

See also: 3D Crazy Eights, 3D Bridge Deluxe, 3D Hearts Deluxe, 3D Pitch Deluxe, 3D Euchre Deluxe, Colin's Classic Cards

Compatibility
Architecture: PPC PPC (Carbonized)

Versions 3.3 and 3.2.1 (Top three DL) are Carbonized and can run on Mac OS's 8.6 and later. 3.3 runs OK on Rosetta (Snow Leopard). Requires CarbonLib 1.6 on Mac OS's 8.6 to 9.2.2

Version 2.2 is for Classic, Mac OS 8.1 to 9.2.2 only.

Comments

MikeTomTom's picture
by MikeTomTom - 2016, October 9 - 11:11pm

I found the official dmg and uploaded it to this page.

Good finding, thanks mrdav. I removed the broken version from the page.

mrdav's picture
by mrdav - 2016, October 4 - 11:27pm

Yes, it is still the case with the current 3.3, MTT. If we can get a copy of the official dmg archive, then I suspect we wouldn't have this problem.

EDIT: I found the official dmg and uploaded it to this page. The problem above does not occur with this.

MikeTomTom's picture
by MikeTomTom - 2016, October 4 - 1:45am

version 3.3 that we have is still missing something...It does not provide an executable file for Classic OS.

Is this still the case with the current 3.3 archive, mrdav? I've been able to repair the carbon app so it now launches correctly on Mac OS 8.6 - 9.2.2 and OS X, and can add this above if needed.

Also, all of the "puppets" and scenes contained in the Colin's Classic Cards .iso (about 200MB's worth) are 100% compatible with the above game and others in the later 3D Deluxe series, if anyone can't locate those elsewhere.

MikeTomTom's picture
by MikeTomTom - 2016, September 27 - 1:00am

the copy of version 3.3 that we have is still missing something...

Thanks for the updated copies, mrdav (esp. replacing the .tgz with .sit).

Version 3.3 does work OK on classic Mac OS's 8.6 and newer, but our current copy has broken symbolic links or alias's inside the package which cause the problem. Workaround solution here (until a replacement can be found) is to open the package and locate the classic Mac executable, make an alias to it and place the alias inside the Game's folder. It also requires CarbonLib 1.6 (screenshot 3).

I actually opened the package, dragged the Contents folder out of the package (then deleted the package). Created a new folder named "3D Spades Deluxe" placing the Contents folder inside and then added the alias to the actual classic app to inside the Game's folder. This seemed to work OK for me (screenshot 5).

[Edit] have since repaired the 3.3 version to a full restore (works correctly in both Classic & OS X) and located a complete collection of compatible "puppets" and scenes for the 3D Deluxe series card games (located in the iPuppet Colin's Classic Cards .iso, linked above).

mrdav's picture
by mrdav - 2016, September 26 - 2:46pm

I think the copy of version 3.3 that we have is still missing something...It does not provide an executable file for Classic OS. Another good reason to look for an official copy of v. 3.3

mrdav's picture
by mrdav - 2016, September 26 - 7:20am

I found version 3.2.1 and copied the plugins from that into the incomplete v 3.3 that we had before, then re-archived v3.3 with the plugins included and re-uploaded. I also found the necessary information to register all the versions.

EDIT: A "official" version 3.3 would be better and, if found, can replace the copy here.

WhosIt.There's picture
by WhosIt.There - 2016, September 26 - 6:58am

Some of the older puppets / scenes don't work with the newer versions of this series of games. I know I copied some from older versions that weren't included with newer versions and then new games don't like them. Sad

MikeTomTom's picture
by MikeTomTom - 2016, September 26 - 1:50am

Upped the classic version of the same game, added puppets (players) from the classic version (combined Hearts & Spades players), as 3rd DL, so the OS X version has a chance of working. Top DL and 3rd DL additional players can be removed if a complete version 3.3 installer for OS X surfaces.

WhosIt.There's picture
by WhosIt.There - 2016, September 24 - 12:26am

The alias should point to a folder within the appliction's bundle.

I do have the original installer, but it's 16MB so unlikely I can upload it with my dial-up connection. It may still be downloadable from Freeverse's website. The game also runs under both OS 9 and OS X.

mrdav's picture
by mrdav - 2016, September 23 - 11:29pm

This upload (version 3.3) needs replacing as it is missing the plugins folder necessary for the game to run. The alias to the plugins is there but there is no plugins folder. Anyone got a replacement to upload?