This page is a wiki. Please login or create an account to begin editing.


3D Crazy Eights

Rating:
Your rating: None Average: 4 (2 votes)
Category:
Perspective:
Year released:
Author:
Publisher:
Engine:
#1
[www].se [ftp].se [mirror].us
3DCrazyEights_1.0.dmg (31.23 MB)
For Mac OS 8.5 - 8.6 - Mac OS X
#2
[www].se [ftp].se [mirror].us
3DCrazyEights1.zip (31.28 MB)
For Mac OS 8.5 - 8.6 - Mac OS X
Emulation
Guides on emulating older games

Freeverse Software's 3D Crazy Eights is a quirky desktop version of this classic card game with interchangeable characters, backgrounds and rules. Characters include Monty the monkey, Zebulon the alien, or Horatio the baking gentleman.

Top DL: The official Freeverse .dmg image of 3D Crazy Eights v. 1.0

2nd DL: A zipped .iso image conversion of the above .dmg as a more universally accessible file for other OS's. If extracting this under a native Mac OS 8.6 - 9.2.2, use MacZip to extract and the Virtual CD/DVD Utility to mount the .iso image.
MD5 checksum & filename: 2f99609b6e58b641693283910866eb7b *3DCrazyEights1.zip

The publisher, Freeverse, no longer exists.

To register, do the following:

1) Set the date on your Mac to 3 September 2004

2) Enter Name: Santa Claus, and Code: S513-5000-1800-0804-U229

3) Register

4) You can now restore the date on your Mac

See also: 3D Hearts Deluxe, 3D Bridge Deluxe, 3D Pitch Deluxe, 3D Spades Deluxe, 3D Euchre Deluxe

Compatibility
Architecture: PPC (Carbonized)

Mac OS 8.6 - Mac OS X

Comments

Katie Cadet's picture
by Katie Cadet - 2017, October 31 - 6:41pm
5

Runs OK on a Power Macintosh 7500/100 (100 MHz PowerPC 601) running Mac OS 8.6 as a minimum requirement for me playing it, but you will need CarbonLib 1.6 in order for the game to function properly. Performance will be greatly improved with the use of a PowerPC G3 or faster, but a 100 MHz PowerPC 601 would definitely be a minimum requirement for this game, but set the game speed to fast in the options screen even when using the 100 MHz 601 processors, since the card animations tend to be a little sluggish on that particular CPU speed though. Another note: QuickTime 4.1.2 will not display the Freeverse Software animation correctly so QuickTime 5.0.2 is required to play both the video and audio of the Freeverse Software animation as another minimum requirement for this game.