This page is a wiki. Please login or create an account to begin editing.

38 posts / 0 new
Last post
Joined: 2009 Nov 14
Yoot Tower color graphic problems (long story...)

I've been playing Yoot Tower for many years. I first played it in 2003 on my family's PowerWave (with its super-large monitor). It ran great but it died several weeks later (it had...problems). Then I installed it on a dual-boot OS 9/OS X computer. Sadly, when my dad and brother partitioned the drive, they really screwed up and corrupted a number of files. It really was a wreck. However, Yoot Tower was one of the few that ran pretty well.

The OS was finally reinstalled in December 2009. A lot of games that had functioned improperly (sound and graphics) were working again, but Yoot Tower mysteriously didn't go so well (by this time I actually bought a boxed copy off of eBay!)

The graphics inside the tower were normal, but the "outside" graphics were screwed up. For example, this is Kegon Falls.

(for contrast, this is closer to what it's supposed to look like, except this was taken during "evening time")

(I got the image off a forum thread somewhere...)

Note in my picture, the bird in the upper-right corner, cutting through the brown and leaving a glitched natural blue in its place (the correct hue).

QuickTime is v5 (2001).

And before you ask: this is running Mac OS 9.2.2 (I *think* the older OS was 9.2.1, but I'm not too sure...) in 256 colors. NOT Classic Environment. I DID completely reinstall the game.

I want to play this game again (this marks the seventh anniversary of me playing, it's a good game to play around Thanksgiving)...can anyone help?


themacmeister's picture
Joined: 2009 Oct 26

I have this all the time, playing games in thousands of colours instead of 256. or vice versa.

It may run in 256 (and look yecchy), but it might be better?!

You could try some of those commercial tools that change the resolution and colour depth before the program launches - this fixed one or two games for me...

Joined: 2009 Nov 14

It's supposed to run in 256 colors, and it is.

Changing it to thousands or millions will screw it up further.

Like I said, it used to run correctly!

Also note that the interior colors are correct.

mathieudel's picture
Joined: 2009 Dec 15

In the first of your screen-shot, we can see a window in the top right corner. Is that a window of the game itself ? If not, I would say it is normal not to have good colors :

When running in 256 color mode, each program defines a subset of the colors it needs and assign them a number to be later referenced : this is the color palette, and only one can be active at a time, the one of the foreground application.

All applications share the foreground application's palette and that can cause a lot of messy colors when not in fullscreen, typically showing things like what your first screenshot shows.

Another possible problem : some applications (lot of games actually) designed to be launched in 256 color mode also change the color palette in real time to create special effects and animations. This is not working if your desktop is set to thousands or millions of colors, here again showing a lot of messy colors.

In other words, applications of this kind must be launched with a desktop set to 256 color, preferably in fullscreen mode, and be kept in the foreground.

Joined: 2009 Nov 14

The game is in the foreground and active, the window you see is part of the game (it has the options, interior/outside/etc). The window's colors (and the tower's interior colors) are all correct. It's just the tower background is incorrect, even if I zoom in or out.

I tried fiddling with the extensions, but to no avail...

Maybe I should download Conflict Catcher 9?

Joined: 2009 Nov 14

But none of the download links work for CC9! Drat!

(Maybe I should look elsewhere. MCP? SheepMyShaver?)

Innes's picture
Joined: 2009 Aug 19

Can you confirm that you deleted the Yoot tower files in the preferences folder

Also, what extensions does it require, perhaps your using newer versions that its not entirely compatible with?

Joined: 2009 Nov 14

@Innes: I never thought of the Preferences folder...if it was just a preference file that was corrupt this whole time, I'd be a very happy man. All I did was delete the folder of the game and its plug-ins (which, by the way, have NEVER been touched, it's an invisible folder).

In fact, I've tried fooling with the extensions for a while, and I don't think anything is wrong.

Alright, I've got my heart set on corrupt preferences. Maybe before my cousins get here, I can fix it.

(takes off running upstairs)

Joined: 2009 Nov 14

No such luck...there's no Preference folder. When I open the Monitors control panel, I can see the 256 colors cycling through. I switched out the panel with the copy from the older change.

Joined: 2009 Nov 14

sorry, meant to say "Preference file"

Joined: 2009 Nov 14

Does anyone have Yoot Tower running on a Mac OS 9.2.2 system?

mathieudel's picture
Joined: 2009 Dec 15

Does anyone have Yoot Tower running on a Mac OS 9.2.2 system?

I'll try it later this afternoon...

Joined: 2009 Nov 14

Here's my extensions, except I think I all but confirmed it wasn't extensions fault...

Control Strip Extension
FBC Indexing Scheduler
Folder Actions
EM Extension
About Apple Guide
Apple Audio Extension
Apple CD/DVD Driver
Apple Enet
Apple Enet DLPI Support
Apple Guide
Apple ì˙ñ{åÍé´èë
Apple Modem Tool
Apple Monitor Plugins
Apple Packet Media Access
Apple Photo Access
Apple QD3D HW Driver
Apple QD3D HW Plug-In
Application Switcher
ATI 3D Accelerator
ATI Driver Update
ATI Graphics Accelerator
ATI MPP Manager
ATI Radeon 3D Accelerator
ATI Rage 128 3D Accelerator
ATI Resource Manager
ATI Video Accelerator
Audio CD Access
Authoring Support
Authoring Support Files
Classic RAVE
Color Picker
Contextual Menu Extension
Disc Burner Extension
DVD Decoder Library
File Sharing Extension
File Sharing Library
Find By Content
FireWire Authoring Support
FireWire CardBus Enabler
FireWire Enabler
FireWire Support
FontSync Extension
Foreign File Access
Global Guide Files
Harry Instruments
Heidelberg CMM
HID Library
Indeo® Video
InputSprocket Extension
InputSprocket MacALLY
Internet Config Extension
Iomega Driver
ISO 9660 File Access
Language Kit Additions
LDAP Client Library
Location Manager Extension
Location Manager Guide
Location Manager Modules
MacinTalk 3
MacinTalk Pro
Macintosh Guide
Microsoft Component Library
Microsoft Framework
Microsoft Internet Library
MPEG Layer-3 DecoderLib
MRJ Libraries
MS Font Embed Library (PPC)
NBP Plugin
Network Setup Extension
NSL UI Library
Open Transport
Open Transport ASLM Modules
QuickDraw™ 3D
QuickDraw™ 3D IR
QuickDraw™ 3D RAVE
QuickDraw™ 3D Viewer
QuickTime Extensions
QuickTime FireWire DV Enabler
QuickTime FireWire DV Support
QuickTime™ MPEG Extension
QuickTime™ Musical Instruments
QuickTime™ PowerPlug
QuickTime™ VR
SDAP Authoring Support
Security Cert Module
Security Library
Security Manager
Security Policy Module
Security Storage Module
Serial Tool
Shared Library Manager
Shared Library Manager PPC
ShareWay IP Personal Bgnd
SimpleText Guide
Software Update Engine
Software Update Scheduler
SOMobjects™ for Mac OS
Sound Manager
SoundSprocket Filter
Speech Manager
StuffIt Plug-Ins
System Monitor Plugins
Text Encoding Converter
Text Tool
Theater Mode
Time Synchronizer
TTY Tool
Type 1 Scaler
UDF Volume Access
URL Access
USB Authoring Support
USB Device Extension
USB Software Locator
VT102 Tool

Innes's picture
Joined: 2009 Aug 19

Yea it runs fine on my 9.2.2 iBook

Two more thoughts, firstly, extension problems can also come from the version number of the extension, i have several different versions of draw sprocket that are needed for different games, if you could find out what version the game has been made for and then check them against what you have, you may find some differences. The information however appears to be lacking from this sites download but if you have a retail disk...

which brings me onto my other question, perhaps there is something wrong with your install disk. You say it worked well before, however this was before you got a copy of the game. Disks decay so perhaps with it not being a very new game, the disk may not be in an optimum state

You could try binning the game and its preferences again, and downloading and running the version from the garden to see if that works

Joined: 2009 Nov 14

It's odd because some colors are off now and others are off (unfortunately, the "off" colors are really obvious). I tried reinstalling the game multiple times: both from the original retail CD (which used to work fine) and the Mac Garden TOAST.

The manual isn't much help at all.

I think it's still the extensions, and I'll cross-reference the extensions folder again.

Joined: 2009 Nov 14

@Innes: Could you tell me what extensions you use?

(it's easy...go to your Extensions folder, select all, copy into SimpleText, and transfer it here. Plain text transfers surprisingly well)

Joined: 2009 Nov 14

I wonder what SOMobjects is. Never noticed it, maybe it might be the problem...?

mathieudel's picture
Joined: 2009 Dec 15

So, I tried the version available here with my iBook USB with MacOs 9.2.2, and I have exactly the same color problems has you have.

I tried to run it under Classic from MacOS X 10.4.11 and something very strange happened : the folder is reported as being empty, but with a size of 100MB. And if I look at it using the terminal, everything seems Ok, but I cannot launc a MacOS9 binary from here....
Anyone did see this before ?

As for SOMObjects, its a shared library developped by IBM to provide distributed (over a network) objects functionnalities to programs that need them. It is only loaded as required so it shouldn't interfere with the game :

Update : I managed to launch the game with classic by moving the folder to another place. Then game the shows the same messy colors.

Joined: 2009 Nov 14

@Mathieudel: Well, that's good that the problem can be recreated, and I'm not just insane (the color problem is independent of what version is used).

Innes, what extensions are you using as that it displays normally?

themacmeister's picture
Joined: 2009 Oct 26

This may be completely out of left field, but it has worked for many others with strange colour depths/resolutions etc. after starting a copied System Folder in Classic Mode...

In OS 9, the display preferences are stored in TWO places: in the Monitors
preferences, and in PRAM.

In order to change display resolution in OS 9, it's sometimes necessary to do
an annoying and elaborate dance, because you need to clear it from both places.
Here's what I did when faced with a similar situation:

1. Start the computer and immediately zap the PRAM by holding down
Command-Option-P-R until the screen flickers and the startup chime bongs 3

2. Release the keys and hold down SHIFT to boot with extensions off. This
prevents the Monitors control panel from loading the preference file and
putting the settigs right back into PRAM again.

3. Locate the Monitors preferences file in the System Folder->Preferences and
trash it.

4. Reboot.

Now you should be able to set your display resolution.

(and reset the date/time and whatever else has changed - startup disk?)

themacmeister's picture
Joined: 2009 Oct 26

Oh, and that third party utility for switching Res/Depth on the fly was SwitchRes!

Get the latest version for OS9.2.2 at the source -

themacmeister's picture
Joined: 2009 Oct 26

Yes, it is a 256 color only game. Does your monitor/OSX support 256 colours? On an official Mac game review, it states that it doesn't switch the colours back, even under OS 7.5.5!

A little treat for you:

Game Name : Yoot Tower
System : Macintosh
Date Added : 2006-08-12 16:51:54
Views : 4575

Unlimited money
Go to the Dolphin Stage and click on the dolphin five times. Then, press [Minus], type bundle, and press [Minus] again. If done correctly, a shining star will appear in the left side of the screen. Quickly click on it to get unlimited money.

themacmeister's picture
Joined: 2009 Oct 26

PS. I had no idea this was a sequel to Sim Tower! I could not tell anything from that screenshot Smile

themacmeister's picture
Joined: 2009 Oct 26

If all else fails, install DarwinePPC and play the PC version -- download here --

Get Darwine PPC here --

Joined: 2009 Nov 14

1) Zapping the PRAM may help. Possibly.
2) How would that help me? The resolution isn't the problem.
3) I set it to 256 colors, and the monitors panel does show the colors cycling through. I know it doesn't switch back automatically, I'm okay with that. I know the dolphin cheat, I think its for the PC version (I always use hex values)
4) It is.
5) The PC version sucks hard, I've used it. It doesn't even cycle through night.

themacmeister's picture
Joined: 2009 Oct 26

2) SwitchRes automatically switches colour depths BEFORE launching certain titles - It uses a different method than MacOS, and can automatically reset the colour depth on exiting the application. It really is a wonderful application - you may never have to visit the Monitors (Monitors&Sound) control panel ever again Smile

EDIT: You must tell SwitchRes which apps to change colour/resolution for - sorry if I gave the impression that it was playing God! Tongue

Joined: 2009 Nov 14

Look, I told you it's not being 256 or not. It's a certain color element inside YT that probably is a system or extension incompatibility, and I'm betting extension.

themacmeister's picture
Joined: 2009 Oct 26

TempJoe, I am only trying to posit that the program is switching the colours incorrectly with the new OS. It *has* been known to happen -- the fact that it doesn't switch the colours back is a sign something is up. The colour mode switch done by SwitchRes completely bypasses the OS entirely, so you can get non-supported colour/resolutions.

I'm only trying to help here Joe. Will the program run with extensions disabled at startup?

Joined: 2009 Nov 14

OK, I'll give SwitchRes a shot.

Extensions disabled do not allow the program to run, I think it needs QuickTime for something, maybe.

Joined: 2009 Nov 14

SwitchRes allows it to run normally in 256 colors without demanding that I change the color depth, but "normal" still involves the off colors.

When I disabled all extensions, it needed QuickTime.

When I added ONLY QT, it switched into some inverted "neon" mode where menus were black, my red desktop pattern became yellow, and so forth. I took a screenshot.

But when the desktop switched back to normal, it was the same as the normal messy colors as "normal", except the waterfall was darker.

MCP's picture
Joined: 2010 Mar 12

What version of QuickTime do you have installed?

Joined: 2009 Nov 14

I think it's v5: the Date Modified all show November 2001.

MCP's picture
Joined: 2010 Mar 12

Version 5 has given me lots of weird problems on my G3 WallStreet running 8.6 before, though I never tried this game. I find it's better to run version 4 or 6 depending on how fast the machine is.

Joined: 2009 Nov 14

And that's probably what happened.

It didn't screw up on my old PowerWave because I think the PowerWave was running 4.
It didn't screw up on the iMac pre-reinstallation because it had probably been upgraded to 6.

I'll download v6.0.3 from Mac Garden and give it a spin...thanks!

mathieudel's picture
Joined: 2009 Dec 15

I've got version 6.0.3 and it doesnt work here either ... But Mac Os X 10.4.11 reports me that's not the latest version when I launch Classic. What is the latest version available ?

MCP's picture
Joined: 2010 Mar 12

Don't thank me just yet! It's just one more thing to try.

Joined: 2009 Nov 14

I've got a new (bigger) problem, but I'll post it in another thread...

Joined: 2009 Nov 14

I installed dice! Time to downgrade to QT4...