This page is a wiki. Please login or create an account to begin editing.


4 posts / 0 new
Last post
Heroofthewild's picture
Offline
Joined: 2020 Mar 15
Sheepshaver here doesn't work no matter what I do!

https://macintoshgarden.org/apps/sheepshaver

It comes bundled with stuff and it first said I was missing a SDLL.Dll file and then I added it in and then it just says unable to start. I would like to use the bundled HDD but don't know how.

Why is there no contact form? You'd think a site as big as this would have a way of contacting for bugged programs or errors.

Comments

24bit's picture
Offline
Joined: 2010 Nov 19

Last time I tried the downloads in 2012, they were working without issues.
What is your host OS, how did you try to inflate the downloaded files?

As written earlier, I think that the files on that page are rather an addition for people already using SheepShaver.
If you are starting from scratch, Emaculation is the place for that and both moderators there do not hesitate answering noob questions for the 1001th time. Wink

In short:
Download the matching SheepShaver build for your host OS from Emaculation.
Add Mac ROM and boot disk e.g. from here:
https://macintoshgarden.org/apps/macos-753-emulators
Run SheepShaver setup to specify all needed paths and settings.
When everything was done right, the emulator will start.

Given you are running a Windows host, Cat_7 at Emaculation has a DL ready for starters.
https://surfdrive.surf.nl/files/index.php/s/eiM6s3UoNN1lMpk/download

Note that you also must install the rcommended GTK Runtime in Windows to use the SheepShaver GUI.
http://www.emaculation.com/sheepshaver/gtk+-2.10.13-setup.exe

As soon as you got the emulator running, you may try the disk images devils advisor did upload.

If setting up the emulator yourself looks like a task too hard to tackle, maybe use something pre-built.
Look for emendelson here: https://www.emaculation.com/forum/viewforum.php?f=33
Here is a direct link to the work of Edward Mendelson too:
http://www.columbia.edu/~em36/macos9win.html
I have to admit, I never tried his package, but it seems to work for lots of people.

Heroofthewild's picture
Offline
Joined: 2020 Mar 15

I finally got it working. Turns out JIT compiler was the problem. Turn it off it's slow but usuable.

24bit's picture
Offline
Joined: 2010 Nov 19

Yup, there seem to be issues with W10 and JIT on some rigs.
My guess was a missing .net framework of the 2.X or 3.X era, all my windows rigs do run SheepShaver with JIT enabled though, but the "latest" are SandyBridge. Smile