This page is a wiki. Please login or create an account to begin editing.


11 posts / 0 new
Last post
modulusshift's picture
Offline
Joined: 2018 Apr 18
Restore CDs for iMac G4 17 inch

I've gotten my hands on the last iMac able to boot OS 9, which I've gotten working, but I'm not thrilled with the 2013 universal installer quality levels. Things like "can't find SimpleText" and stuff like that. I want a really solid install, so I'm turning to the recovery discs...which I didn't get with the Mac.

I've been told that I can just pick an installer that's more recent than the Mac, but out of desire to keep things neat, I'd like a copy of the correct ones. And I haven't found them, so it would certainly be nice to have a copy online somewhere for other people.

According to the comments on the page, these aren't correct. According to Mactracker, the correct media contain 9.2.2 with ROM 9.5.1, as well as OS X 10.1.5.

Comments

mrpippy's picture
Offline
Joined: 2015 Jun 7

I have the same machine, unfortunately I haven't seen the restore CDs posted online anywhere. It would be nice to have all the bundled software, but I used an eMac 9.2.2 install ISO and it's a solid/basic OS 9 install. It's probably one of the 9.2.2 images available here:

http://macintoshgarden.org/apps/mac-os-install-cd-library

modulusshift's picture
Offline
Joined: 2018 Apr 18

Hmm, actually, that link you posted includes an "iMac_Install.toast_.sit" that, after looking the part number on the picture up here: http://www.welovemacs.com/6913638a.html

the description specifically lists "iMac 17 inch Flat Panel" as supported...this could be the disc? I'm trying to look up more info.

sfp1954's picture
Offline
Joined: 2013 Dec 29

Details of the iMac Install CD.
Basically compatible with any G3 or G4 Mac except the PB3500 (AKA Kanga).
MacOS Version 9.2.2
CD Version 1.1 Date 2002
Part #691-3658-A

Compatibility information

IMPORTANT
• Mac OS 9.2 supports Mac OS X compatible computers
You can install this version of Mac OS 9.2 on any of the following computers: Power Mac G4,
Power Macintosh G3, PowerBook G4, PowerBook G3 (except the original PowerBook G3),
iMac, and iBook.

-------
But both the eMac disks on my page have similar compatibilty.
If you need OSX as well you should install 9.2.2 first and then whatever version of OSX you prefer.

http://macintoshgarden.org/apps/mac-osx-mac-os-10-ppc

sfp1954's picture
Offline
Joined: 2013 Dec 29

There is also the four CD 2003 iBook restore. 9.2.2 and 10.2.4.
The four CDs that start with iBook on the same page.
http://macintoshgarden.org/apps/mac-os-install-cd-library

modulusshift's picture
Offline
Joined: 2018 Apr 18

I gave it a shot, it starts to boot, but it goes to a black screen and stops seeking the disc during boot up. :/ Worth a shot. Booting without extensions doesn't help, and it doesn't look like the ROM is a late enough version, it's 9.1.1 instead of 9.5.1.

I think I'll try the eMac disc in the next couple days.

z970's picture
Offline
Joined: 2016 Aug 26

I have the mid-'02 17" discs for OS 9.2.2 with ROM 9.5.1, but the OS X install is for 10.2.

How is that?

mrpippy's picture
Offline
Joined: 2015 Jun 7

It'd be great to get that uploaded! I think those are the ones we're looking for, the 17" came out in summer 2002 with 9.2.2 and 10.2

z970's picture
Offline
Joined: 2016 Aug 26

Ask and ye shall receive!

http://macintoshgarden.org/apps/imac-g4-17-summer-2002-software-restorei...

SideSwipe9th's picture
Offline
Joined: 2019 Mar 28

Hey,

Sorry for the necrothread. Do you still have those discs? I just purchased this model of G4 from eBay, and I want to install OS 9.2.2 onto it. Unfortunately this upload only seems to have OS X?

kalibatov's picture
Offline
Joined: 2020 Mar 27

Thank you for sharing this, can I use these CDs for iMac G4 17 inch 2003 1GHz.