This page is a wiki. Please login or create an account to begin editing.


8 posts / 0 new
Last post
FlatRound's picture
Offline
Joined: 2014 Jun 10
Quarterstaff Game

Hi everyone. I can get Quarterstaff to run on both Mini vMac and Basilisk II. There are a couple problems. The map and images of objects in my inventory do not work. I just get a blank space where the picture would be. Also, I am getting no sound whatsoever. Part of playing this game was the sounds! Can anyone help me out? I have no idea what the problem might be.

Comments

Temporary Joe's picture
Offline
Joined: 2009 Nov 14

It seems to work fine in my set-ups. Did our copy get corrupted somehow? Did yours?

FlatRound's picture
Offline
Joined: 2014 Jun 10

It's possible my copy got corrupted but I don't have a file list to compare against. In the Quarterstaff directory, I have a file titled "FileofCrets" which is a 0k file. I just can't help but think this got mangled somewhere in the process of installation because it's the only file, aside from "Icon_" that doesn't seem to make sense. Honestly, it seems like it's missing some necessary file because everything else seems to be working just fine, except the icon images, the maps, and the picture window pics. I could be wrong, however. Can you send me a list or screenshot of files present after it's unarchived?

Temporary Joe's picture
Offline
Joined: 2009 Nov 14

Yeah it definitely seems like you're missing files, here's my copy. I can hear sounds and see the map just fine, and can hear Titus grunt when I send him in a way that doesn't exist.

http://dl.dropboxusercontent.com/u/8243916/qstaff.png

FlatRound's picture
Offline
Joined: 2014 Jun 10

Bizarre. I seem to have all the same files, including the following "Icon_", "Quarterstaff_RSRC", "Quarterstaff_RSRC2" and another folder with images/descriptions of the coin and parchment. When I load the game (in both vMac and Basilisk) the program asks me to find "Quarterstaff_RSRC". It then loads with the same problems I mentioned before. This is frustrating. I seem to be having problems with sound on several other old games as well. I don't know if it's the emulator or what. I'm using a Windows laptop not a Mac but I don't know if that's the cause. Maybe the emulator is missing something?? Any ideas? Would Sheepshaver work better?? Thanks for the screengrab

Temporary Joe's picture
Offline
Joined: 2009 Nov 14

Oh yeah, there's also FileofVerbs (12k), Quarterstaff/RSRC (621k, last modified 1988), Quarterstaff/RSRC2 (758k, last modified 1988).

Those should be slashes, not underscores.

Try modifying them to slashes within the Mac environment, if not, it's probable that Windows mangled the resource files in unzipping.

FlatRound's picture
Offline
Joined: 2014 Jun 10

Success!! Changing the underscores to slashes worked. Now the maps, the sound, and the images are working. Thank you, thank you!! You're my new best friend! =)

Temporary Joe's picture
Offline
Joined: 2009 Nov 14

No problem. Cool