This page is a wiki. Please login or create an account to begin editing.


10 posts / 0 new
Last post
Minimum91's picture
Offline
Joined: 2009 Aug 14
PowerMac G4 AGP No Video / No Boot

Hi,

Suddenly one of my dear Macs has decided to give up. Heres the story.
I ordered what seemed to be a good condition 22" Apple Cinema Display with DVI. It arrived, so I took a most appropriate matching machine - A 450MHz PowerMac G4 AGP. Even the color of the Apple logos perfectly matched (not technically relevant, I know). Later I found out that the odd 62W power adapter was somewhat fried, so I took to a local repair shop to see what they could do. Fast forward to now - this machine hasen't been booted since that moment, which is about 4 months. Today I decided to play some games on it, fetched an also perfectly matching 15" DVI Apple Studio Display, plugged it in and pressed the power button. To my surprise the monitor was not showing anyting. The machine did chime and booted successfully to Jaguar. I could tell that because I could change the volume and hear the corresponding sound. First though was that the dud Cinema Display has fried the video card, I hade a spare RAGE card, so I swapped it, booted but the same behaviour persisted. With that in mind I started looking up the issue on the web and came to the inevitable suggestions - resetting PRAM, PMU. So I tried both to no success, and now it's even worse! First the machine stopped making the chime, and after some more more twiddling around - replacing the motherboard battery, unplugging everything and leaving it alone for 10 minutes, now it's making a very strange ABRUPT chime! I've never heard a machine do anything like that! Attaching a video demo: https://youtu.be/S0GD1K-cJw0

Comments

scott Praed's picture
Offline
Joined: 2010 Oct 30

You need a new monitor or new 62W Adapter.
The computer can't find the system on hard drive. Repair permission on drive. Or reinstall the system.
Sometime the system go bad and need to reinstalled. That happen to me. My permission on drive got corped in mac os x 10.5.8. The computer will boot in mac os x system when permission is corped.

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

Can't add anything very helpful, sorry. Even though the startup chime is truncated, it doesn't sound like a "Sad Mac" chime (e.g.; broken glass, or beeps). It also appears to be booting up, I can hear fans running and possibly the hard drive being accessed. Did you check if the speaker is connected correctly to the logic board? Were you able to test the displays & their connecting cables as working on any other Mac/PC? Or introduce another, known to be working display to the G4?

24bit's picture
Offline
Joined: 2010 Nov 19

I feel with you Minimum91.
Swapping parts looks like the only way to sort out things it seems.
Keep in mind though, that a bad graphics card may partially destroy the motherboard bus and that a half dead AGP bus may destroy spare graphics cards in return. Sad

I had that issue with a GMA945 based rig some time ago, different architecture, same problem.
In the end I had two motherboards and two graphics cards fried, cpus, RAM and drives remained undamaged at least.

Minimum91's picture
Offline
Joined: 2009 Aug 14

@24bit Damn sure hope I didn't fry the other video card I put in it.

@Knez Actually, I think I have one in the PowerMac G3 I have lying around! Thanks for the idea.

@Gary Sounds like an idea worth trying.

Knez's picture
Offline
Admin
Joined: 2010 Feb 11

You don't happen to have a PCI graphics card to try with? Done the usual things (zapping PRAM, reset the PMU with the Cuda button)?

Gary's picture
Offline
Joined: 2011 Jul 21

>now it's making a very strange ABRUPT chime!

I have one that did the same thing. After much trial and error I added a second disk and was able to boot from it. Ultimately I tossed the original system disk.

Gary

Minimum91's picture
Offline
Joined: 2009 Aug 14

I tried the following today:
1. Remove all RAM sticks, boot once to see if it reacts to changes - it did. Then reseated all the RAM and tried the PCI RAGE card from the G3 tower and indeed it worked
2. Put the AGP card back in and it's not showing anything. I guess it's fried.

More: after some more testing it seems like the DVI output on the video card is now working. The only mistery is the ADC connector which does not work with any display. Could It be these models don't support powering Apple Studio or Cinema Displays via ADC port?

sfp1954's picture
Offline
Joined: 2013 Dec 29

More likely just the ADC port is blown. It's a bad design in my opinion to ask the PCI bus to power a video monitor. I once sold a G4 cube that I had used without problem via the DVI port (or VGA, I forget which 2nd port it had) and when the new owner tried to use it via the ADC port he found that it was non-functional. So it's not an uncommon occurrence.

Minimum91's picture
Offline
Joined: 2009 Aug 14

Final:

I came to the conclusion that this model in fact does not support powering ADC monitors as the extra 3 pins do not attach to anything, unlike my Quicksilver and MDD that have these special 3-pin plugs.

This is the model that was the first one to connect to the 1999 22" Apple Cinema Display with DVI.