This page is a wiki. Please login or create an account to begin editing.


2 posts / 0 new
Last post
Fortuna Wave's picture
Offline
Joined: 2009 May 23
Mac OS Anthology fail to install system software correctly?

In Mac OS Anthology, there are some system disk images refusing to install system software and/or other software during installation, mostly affecting 7.6.1, 8.0, 8.1, 8.5 and 9.0.4 installers.

For example, I attempting to install 9.0.4 International from the Anthology 2000 Disc 6. Unfortunately, the installation stops here when this error message appear:
macos904installerror-anthology
click on thumbnail to view full image

The failed installation were caused by the "Please insert the disk" error, like this below (using Installer 4.0.8, taking example of attempting to install ISP Country Settings from the same disk image):
macos904anthology-pleaseinsertdisk

Even I re-create the installer source folder using Disk Copy, mounting and install from there, another error message appears:
macos904anthology-notcorrectdisk

The Installer checks every file creation date from the source folder/disk and if the file have the different creation date (other than zero-value creation date), the Installer will reject the source folder/disk and show the error message like above.

I have checked the disk image "Z693-2454.img" to see the contents, everything looks like an original retail OS 9 installer sans the System Folder. However in "Get Info" of this disk image, I saw this:
macos904anthology-hfsplus
Apple created these images with HFS+ file system format. Why these disk images in the anthology DVDs starting with 7.6.1 are created with HFS+ instead of HFS?

I'm going to retrieve the creation date of the Installer script that causing the error during installation. Inside the Mac OS 9 install folder (located in "Software Installers/System Software" from the disk image), there are four files:

  • Big System Morsels (creation: 26 Sept 1999, 3:00am / modified: 19 Jan 2000, 8:00pm)
  • Install System Software (creation: 11 Jan 2000, 8:00pm / modified: 28 Jan 2000, 8:00pm)
  • Installation Tome (creation and modified: 27 Jan 2000, 8:00pm)
  • System Extras (creation: 26 Sept 1999, 3:00am / modified: 4 Oct 1999, 7:00pm)

I comparing these dates from the anthology disk image with the retail OS 9.0.4 CD image (English-International). The original creation date for the Mac OS 9 installer (from the retail CD):

  • Big System Morsels (creation: 25 Sept 1999, 8:00pm / modified: 19 Jan 2000, 12:00pm)
  • Install System Software (creation: 11 Jan 2000, 12:00pm / modified: 28 Jan 2000, 12:00pm)
  • Installation Tome (creation and modified: 27 Jan 2000, 12:00pm)
  • System Extras (creation: 25 Sept 1999, 8:00pm / modified: 4 Oct 1999, 12:00pm)

Looks like the anthology version of 9.0.4 Installer have changed the creation dates seven/eight hours later. Is this caused by HFS to HFS+ conversion?

The only way I can bypass the creation date check and perform installation as usual is to use ResEdit and change all "infs" resource IDs creation date into zero value creation date.
macos904anthology-resedit1
Before
macos904anthology-resedit2
After

I have to do it not just base Mac OS 9 installer script file, but I also need to change Internet Access (including ISP Country Settings, Microsoft Internet Explorer, Microsoft Outlook and Netscape Communicator installer scripts, which is part of Internet Access), English Speech Recognition and Language Kits installer scripts (since these installers also have the same "please insert the disk" error). However this method could take some time since the MSIE, Netscape and Outlook installer script "infs" resource have hundreds of IDs to change creation date value into zero-value.

Comments

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

Thanks for looking at this. You are quite right in your assessments.

I also got the same errors with that "Z693-2454.img" disk image - It's looking fubar to me.

Also, any CD sized img on the Anthology from prior to Mac OS 8.1 is HFS+ formatted Tongue

I just had to jump through hoops to install French Mac OS 7.6.1 from the 1999 Disk 1 DVD image. I ended up having to mount the DVD image in OS X, mount the French image "F693-1928.img", copy the contents to Basilisk II running OS 7.6.1, get Disk Copy 6.x to create a new HFS image, then run the installer from that. - I tried other methods before this, such as get OS X Disk Utility and Toast to convert and create new images, both of which failed for various reasons, but Disk Copy 6 worked for me and I was then able to install the OS, OK.

It's looking like the Anthology requires some hard work to get a successful install for some (if not much) of it. YMMV I guess.