This page is a wiki. Please login or create an account to begin editing.


5 posts / 0 new
Last post
peapod's picture
Offline
Joined: 2010 Jun 4
Mac OS 9 color and sound problems :(

i have come very far in my quest to play odell down under. but now i cant seem to get sound on OS9 to work. In the directions it says select "built-in" under sound output in the control panel, however "built-in" is not an option for me. and im stuck without sound.

Also, i cant play certain games because they only run in certain color modes???
I also get messages saying that i cant play certain games because "You dont have enough memory. Zero K is needed and you only have 266,500 available."
uh......what?
Any hint would be greatly appreciated.
THANKS

Comments

IIGS_User's picture
Offline
Joined: 2009 Apr 8

I also get messages saying that i cant play certain games because "You dont have enough memory. Zero K is needed and you only have 266,500 available."

This is to set in the "Get Info" dialog box of each application, in the Memory Management section in the bottom of that window. Try to increase the memory amount allocated to the particular app.

macgirl84's picture
Offline
Joined: 2009 Oct 26

Are you running this in an emulator or on a vintage Mac?

I just downloaded Odell Down Under and loaded it into my 9.0.4 Sheepshaver, and I've got it running with sound.

My wee little fish are currently moving at warp speed, but that might be BetterTouchTool interfering, so I might try playing it again with BetterTouch disabled.

watchsmart's picture
Offline
Watcher
Joined: 2009 Apr 10

Did you try this note from the guide:

If the “Apple Audio Extension” happens to be installed in the Extensions folder, remove it.

MikeTomTom's picture
Online
Joined: 2009 Dec 7

Also I have read and acted upon :

Remove or disable the Apple Audio extension.
If you running OS 8.5 through 9.0.4, go to the Sound control panel in the Apple Extras folder to enable it.
Remove the Sound Preferences and ControlStrip Preferences from the Preferences folder and restart.
Also make sure you do not have the extensions "Sound Manager" and "Apple Audio Extension" installed. Remove if present.

This worked for me. Actually, I also swapped out the "Monitors & Sound" Control Panel in the Control Panels folder with the separate "Sound" and "Monitors" Control Panels located in the "Apple Extras" folder (then removed any of the above preferences from the System's Preferences Folder, etc;).

To disable any active Control Panel or Extension I use the "Extensions Manager" GUI (also a Control Panel). - Go: Apple menu (Apple icon at top left corner of screen) > Control Panels > Extensions Manager.

When introducing new System Extensions or CP's to the Mac OS (in this case the icon of the "Monitors" CP and the "Sound" CP from the "Apple Extras" folder), drag the icon over onto the closed System Folder's icon and release the mouse. You will then be asked if you want to move these items to their correct locations... Yes you do, so [OK] it. Then Reboot to get your changes to take effect.

However and whatever you do to get sound working here, out of all the Mac OS's that you can run on SheepShaver, I think the most stable Mac OS version on SheepShaver is Mac OS 8.6 (or perhaps I should say "I find Sheepshaver behaves better if running Mac OS 8.6") - IMHO.