This page is a wiki. Please login or create an account to begin editing.


14 posts / 0 new
Last post
MikeTomTom's picture
Offline
Joined: 2009 Dec 7
Warning messages appearing

Getting lots of warnings appearing on the APPS and other pages right now. Just me, or early signs of an outage?

Warning: Duplicate entry '8723611' for key 'PRIMARY' query: INSERT INTO watchdog (uid, type, message, variables, severity, link, location, referer, hostname, timestamp) VALUES (8392, 'php', '%message in %file on line %line.', 'a:4:{s:6:\"%error\";s:12:\"user warning\";s:8:\"%message\";s:576:\"Duplicate entry '8723611' for key 'PRIMARY'\nquery: INSERT INTO watchdog\n (uid, type, message, variables, severity, link, location, referer, hostname, timestamp)\n VALUES\n (8392, 'filefield', 'FileField was trying to display the file %file, but it does not exist.', 'a:1:{s:5:\\"%file\\";s:50:\\"sites/macintoshgarden.org/files/apps/ADock-301.sit\\";}', 4, '', 'http://macintoshgarden.org/apps', 'http://macintoshgarden.org/tracker', '220.233.85.1 in /var/www/html/includes/database.mysqli.inc on line 134

Above quoted, is what I'm seeing on the APPS pages (a small portion of).

See ya's in a day or two? Wink

[Edit] Have changed the subject title from "Lots of warnings appearing" to "Warning messages appearing".
(a) Because the topic has changed from its original intent as a generic "Uh-oh" alert.
(b) And the thread is still being used (I thought it would be a one-off message that could be deleted after the initial post, but it seems to keep re-appearing from time to time..

Comments

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

Well, not down completely, but still getting 'em (with every post)

user warning: Table './macintoshgarden/watchdog' is marked as crashed and should be repaired query
[...]
etc, etc, etc;

Fixable soon, I hope?

vortex's picture
Offline
Joined: 2013 Feb 11

...

Ryan Alexander's picture
Offline
Joined: 2013 Feb 1

I get these types of warnings EVERY time I post a comment, edit a page or whatever.

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

Well, the above (initial) warnings by me were from when the site was about to go down, sometime back in mid 2012... I kind of hoped subject topics like this would be deleted by an admin once they were resolved...

Current errors tho' are from whenever a post is made (or an upload, uploaded) and go along the lines of:

user warning: Duplicate entry '8392' for key 'PRIMARY' query: INSERT INTO user_titles_posts (uid, posts) VALUES (8392, 1) in /var/www/html/sites/macintoshgarden.org/modules/user_titles/user_titles.module on line 307.

with every post made...

Hopefully this will eventually be recitified.

And Admins, if this newer one does get resolved; Please delete this old subject & thread Wink

MasterDavidGoodmen's picture
Joined: 2013 Mar 25

I just ran into this problem.  It resulted in a double-post, not the single reply I had expected.  I came here looking for instructions to delete my extra post...
At least now I know not to try posting again!  Smile

Balrog's picture
Offline
Joined: 2009 Apr 24

Fixed

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

Fixed

"user warning: Duplicate entry '8392' for key 'PRIMARY' query: INSERT INTO user_titles_posts (uid, posts) VALUES (8392, 1) in /var/www/html/sites/macintoshgarden.org/modules/user_titles/user_titles.module on line 307."

Still getting this with each post, here.

grawlix.computing's picture
Joined: 2009 Jun 1

I get a very similar error when I add apps. The node still gets created, but I wonder what might be getting screwed up. Here the exact text of the error message:

user warning: Duplicate entry '113' for key 'PRIMARY' query: INSERT INTO user_titles_posts (uid, posts) VALUES (113, 1) in /var/www/html/sites/macintoshgarden.org/modules/user_titles/user_titles.module on line 155.

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

This one has been here for months (give or take a 'value' id # & line #) and long before balrog's "fixed" post a couple of messages back. Even when the site goes down with a humongus amount of screwed up raw code, this one has never gone away.

supernova777's picture
Offline
Joined: 2013 Mar 18

i have got these error messages pretty much everytime i ever used this site since march

grawlix.computing's picture
Joined: 2009 Jun 1

I guess it will be a surprise to no one that I get that exact error message when creating a new topic in the forum as well.

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

And of course you realize that the error code printing id '113' is identifying you? Mine is '8392'...

So 1984.

Maybe I'll change my name from "MikeTomTom", to "8392", just to simplify reading error messages Wink

grawlix.computing's picture
Joined: 2009 Jun 1

My guess is the problem lies in the other field in the primary key. If that "1" is a postid, it seems unlikely that "1" had not already been used.

If the table is keeping track of the number of posts made by a particular user, then a "1" looks as if it is unable to read a previous value to make the incrementing mechanism work. Also, it's odd that the count would be part of the primary key. Sort of weird.

If you search out bits of that error message to try to find a drupal discussion, most of what comes back are reference to the Macintosh Garden. The stuff in drupal forums is apparently no longer online.