This page is a wiki. Please login or create an account to begin editing.


2 posts / 0 new
Last post
Offline
Joined: 2011 May 20
LC III (No boot) Possibly ROMS

My LC III which used to work fine has died on me.

The problem started with it taking long to chime but it would eventually work but now all i get when i switch it on is a small sound from the speaker (the one before the chime) and that's it. Black screen and no chime.

I had tried re-seating the socketed ROMS and the FPU and i tried zapping the P-RAM, re-seating the RAM and VRAM and also tried switching it off and on again quickly but nothing works. Also tried disconnecting the HD, keyboard etc.. I also replaced the battery for a brand new one.

I suspect it could be the ROMS because the PSU and all its voltages are fine and the speaker makes that sound like it would do just before the chime. At some point (i don't know if it was before the non booting or after) i had accidentely put the ROMS in badly with the result that they got REALLY hot.

I need a pair of ROMS to test... Has anyone got any or know where i can get/buy them from ?

Either that or is they anything else i can try ?

Comments

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

@dougal: You posted of this problem back in April '12, which I am sorry to hear, is still unresolved. It is a good chance that you have indeed done some irretrievable damage when re-socketing the ROM wrong and attempting to run the LC III.

You might be better off to wait for a working LC III to come up on eBay (or from any other source) and salvage what you can from your current LC III for parts.

A whole LC III might be easier to source than a replacement ROM, ironically.