This page is a wiki. Please login or create an account to begin editing.


5 posts / 0 new
Last post
m68k's picture
Offline
Joined: 2016 Dec 30
I apologise, its Basilisk + slirp again

Hi Folks,

I should know better, but I keep messing around with Basilisk II on Android and MacOS 8.1
I installed the OpenTransport 1.3.1 pack and I use a static IP#. I can ping myself at 10.0.2.15, but trying to ping the internal router at 10.0.2.2 fails just as totally as trying to resolve *any* kind of outside domain name.
I am not even sure if the virtual NIC is up or if I am just fiddling around with the internal loopback interface.

Maybe I am missing an extension or a control panel, or I am using the wrong ROM version?
Or maybe it just doesn't work under Android - but how to be sure?

Comments

24bit's picture
Offline
Joined: 2010 Nov 19

Somebody with Linux coding experience could possibly find the culprit.
SLIRP is working with Basilisk II, except for the Android build.
When nobody picks up sticks, you may have to build the Android app from source yourself and compare sources for e.g. OSX and Android to spot the missing part.

m68k's picture
Offline
Joined: 2016 Dec 30

So it couldn't be that I'm just missing some extension here?

24bit's picture
Offline
Joined: 2010 Nov 19

No, I don´t think so.
From the guest MacOS side all bits and bytes should be in place with a full install.
It´s a flaw in the Basilisk II build most likely or a compatibility workaround maybe.

m68k's picture
Offline
Joined: 2016 Dec 30

I disabled a lot of extensions, when I tried to debug my crashing screen. Turned out I was just using the wrong ROM, but I'm not sure I moved all the right extensions back in place.