This page is a wiki. Please login or create an account to begin editing.


12 posts / 0 new
Last post
TenPoundHammer's picture
Offline
Joined: 2012 Oct 21
Games running too fast

Some games tend to run ungodly fast in an emulator. Is there a way to slow them down?

Comments

Tanara Kuranov's picture
Offline
Joined: 2013 Jan 9

I believe mini vMac throttles the CPU, depending on what model it's emulating, at least from my experience when I recorded StuntCopter. If you do custom builds of mini vMac, you can go all the way back to a 128k. Don't know what you're trying to emulate, so I can't really help you out specifically.

TenPoundHammer's picture
Offline
Joined: 2012 Oct 21

It's a color Mac game called Bugs Bannis, and I'm running it in Basilisk.

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

One thing you can try for these super fast games is to turn off "Enable JIT Compiler" before you launch the emulator (if you are running a JIT version of Basilisk/SheepShaver that is).

The B2/SS Mac runs super slow but the game might then run at a decent speed. This worked for me with Power Pete.

Turn back on the JIT Compiler when you're done.

TenPoundHammer's picture
Offline
Joined: 2012 Oct 21

^ JIT? I don't see that anywhere.

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

So then... What version of Basilisk II are you running?

TenPoundHammer's picture
Offline
Joined: 2012 Oct 21

Basilisk II 1.0.

Also, the game I was trying to run now crashes on startup every time.

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

Basilisk II 1.0.

Doesn't mean zip to me.
If it's GUI looks like any of these pix (scroll down page) when you start it up and BEFORE launching into a 68k Mac OS...

The tab at the top right side of tabs will say "JIT Compliler". Click it and turn the JIT Compiler off.

Also, the game I was trying to run now crashes on startup every time.

After booting up to whatever Mac OS you run on Basilisk II, go into it's System Folder > Preferences folder and delete any Preference file created by that game (if any). Start over.

TenPoundHammer's picture
Offline
Joined: 2012 Oct 21

I turned off JIT compiler. The game doesn't have a prefs file, but I was somehow able to get it to run again. however, with JIT off, it's still running at ludicrous speed.

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

Sorry it didn't help. I see on the games page that G3 Throttle is recommended to use with this game to slow it down, but that only works on G3/G4 hardware, not Basilisk II.

IIGS_User's picture
Offline
Joined: 2009 Apr 8

If the game is an 68k game, developed for Macintoshes up to Quadra, you could try to run it in SheepShaver or its hardware PowerMac comparison, because the PowerPC processor executes the 68k calls line by line (which slows it down) , instead of compiling the 68k application at once and running it afterwards.
Good example: Macintosh Garden/Games/The Settlers 2

dukeraoul's picture
Offline
Joined: 2009 Apr 24

If you're still having trouble, try running the game in Fusion inside DOSBox. I'm able to run some color 68k games in Fusion that run too fast in Basilisk II. There's an installation guide here: http://www.emaculation.com/doku.php/fusion_setup_guide