This page is a wiki. Please login or create an account to begin editing.


4 posts / 0 new
Last post
Gary's picture
Offline
Joined: 2011 Jul 21
G4 (Quicksilver) won't turn on

This morning everything was fine. This afternoon, the Powermac has no chime and the power light turns on but fades out quickly.

I suspect a bad power supply but before I tear the machine down, I thought I'd ask you about your repair experience.

If you've had a Quicksilver that didn't turn on and you got it working again, did you fix it by:
1) replacing the internal battery
2) doing a cuda reset (and it's cousins)
3) replacing the power supply
4) repairing the power supply
5) doing something that I didn't list

Gary

Comments

timjomartin's picture
Offline
Joined: 2009 Sep 21

I have had very similar experiences with a pair of QuickSilvers (2001 & 2002) - as you suggest power supply problems are the likely culprit if your pram battery is good - I’ve achieved temporary fixes by both switching power supplies between machines - initially as a test - but it temporarily had both machines working again and then when the problem resurfaced I reduced the power load removing the least used pci extension cards and unplugging unused optical and zip drives power leads - in the end the problem reoccurred anyway and I now only have one functioning QS - but in the interim I’ve moved on to a MacMini - so the QS’s are in the attic - but I keep my eye out for power supplies for them but the cost seems prohibitive - so I’ve moved on - loath to get rid of the souped-up QS 2002 (ex800) upgraded to Sonnet Duet 1.8 machine though as its just about the fastest machine that can run classic native and mines got sata usb2 and fw800 fitted ...

wazeem's picture
Offline
Joined: 2011 May 25

Interesting, I have identical situation. I got the QS from ebay sold with dead PSU. So after searching for a replacement and deciding it was going to cost too much, I adapted a standard ATX to fit, there is a website with all details needed. The outcome is, it works fine but has exactly the same problem, every now and again, I press the little power on button, it lights and fades out, no power up. I've tried cuda, battery and usually after some fiddling the QS powers up and will be ok for a few days. So it maybe safe to conclude it's not the power supply, but maybe something to do with the circuit that triggers the PSU to start, I recall I did force the signal. A guess, maybe the signal from the button is too short (in time duration) and so the PSU drops out ??

MadMac's picture
Offline
Joined: 2010 Mar 20

I ran in a similar situation once. It must be a RAM problem, at least it was for me (2-512mb & 1-128mb)

1: Open the case.
2: Unplug the power supply wires to the motherboard (very important step before doing sth there)
3: Remove your RAM or place it in a different position (Remember that RAM in these machines are
recognized by pairs, if u have 2 512mb place them one next to the other and so on)
4: Reconnect the power supply wires to the motherboard and turn the machine on.

if nothing happens, you ll have to start the machine from a startup CD, Tiger/9/or other disk utility, (by keeping pressing the right button of your mouse at the startup it will open the CD/DVD drive).