This page is a wiki. Please login or create an account to begin editing.


2 posts / 0 new
Last post
danco's picture
Offline
Joined: 2020 Nov 18
Canvas 8

I've just discovered Macintosh Garden, and have been downloading some software that I used to have and liked but gave up on as they did not run on new Macs. Basically OS 9 and earlier stuff that I run under Sheepshaver.

One of the programs is Canvas 8, but I am having some trouble with it. When I try to run it, it complains that I need CarbonLib 1.3.1 or higher. But I already had this (not sure exactly which version), and I actually downloaded CarbonLib 1.6 and installed it. And I still get this error message!

Comments

MikeTomTom's picture
Offline
Joined: 2009 Dec 7

Canvas 8 requires a minimum of Mac OS 9.0.4, which I guess is the OS you are using here.

I don't get that issue, as it is working for me. Screenshots on that page are also mine, running under a Mac OS 9.0.4 + CarbonLib 1.6, on Sheepshaver.

The only thing I can think of (if you are new to Sheepshaver) is that any software you install should be done only after the installer program has been copied to inside of an emulated hard drive (the emulated startup disk or additional emulated HDs, or from mounted HFS CD or floppy media). And only then run the installer app.

That is, never run installer apps from the common disk drive shared between host and emulated environments, or if dragged to the desktop from the shared environment, as technically they are still inside of the shared environment and not in the emulated environment. If that's what you've been doing then applications will likely not behave as well as they should.

But if that's not what you are doing, then I can't think of any other reason why it isn't working here, sorry.