This page is a wiki. Please login or create an account to begin editing.


6 posts / 0 new
Last post
Protocol 7's picture
Offline
Joined: 2010 Aug 7
Can't get CDROM Toolkit to keep working.

I've tried various different versions with an old external CD drive (that's in the supported devices list) but at best it will only mount a CD the first time it's installed. After a reboot it will never mount a disc again even though the driver is loaded and everything appears to be working. The Finder stops responding and I have to reset the Mac.

The freeware CD Sunrise driver works fine but I'd like audio support and perhaps hybrid discs too (anything other than a plain HFS disc is unreadable with it).

I'm doing most of my "testing" on my LC III which has 7.1, 7.5.3 and 8.1 installed. I'm mostly using 7.1 for this but have tried 7.5.3 too with no joy.

Update:

I've noticed that if I have the disc in the drive during startup it will mount. But it doesn't like mounting discs inserted when the system is running.

Comments

themacmeister's picture
Offline
Joined: 2009 Oct 26

I had exactly the same issue with CDT, and could not find any resolution to the problem, except to go to a competing product... Cannot remember the name from memory, but it was something like Turbo-CD or something?!

Protocol 7's picture
Offline
Joined: 2010 Aug 7

Well at least I'm not the only one having trouble.

Thanks for the tip. I think I've managed to find the software you used. Was it RapidCD? It seems to be working here so far. CD Audio works with it's own CD player controls. The Apple CD Player doesn't seem to like the drive.

The only thing it won't do is mount any of my (mainly 700mb) CDRs, but then neither could CDT. Only CD Sunrise can mount those.

themacmeister's picture
Offline
Joined: 2009 Oct 26

It was RapidCD -- did I post it here? I may have... Smile This worked perfect for me, and along with some Adaptec extensions, I was able to mount any disk I came across.

Also, the only MP3 player software that did not skip when ejecting a CD, was MacAmpLite.

Protocol 7's picture
Offline
Joined: 2010 Aug 7

Someone put it here but I don't know who (doesn't show the uploader when you find it in a search). Might have been you Smile

What Adaptec extensions do you mean? UDF and Joliet? Or are there others that might make my CDRs mount ok? I tried RapidCD with the Adaptec UDF extension in 8.1 (UDF requires 7.6 minimum) and it didn't mount the test CDR, just hung the Finder.

I tried a bunch of other utils last night and have so far settled on CD/DVD Drive TuneUp. It mounts everything and audio CDs play fine in the Apple player (though I'm using NetCD now because of the freedb lookup). Only niggle is it only mounts the HFS part of a hybrid disc, but that's not a big deal.

themacmeister's picture
Offline
Joined: 2009 Oct 26

Glad to hear you found a happy medium... I haven't used RapidCD since I was using an SE/30!

That takes me back... sigh