This page is a wiki. Please login or create an account to begin editing.

7 posts / 0 new
Last post
Joined: 2009 Aug 8
BasiliskII Titanic AOOT Performance

Hiya folks, to keep it short:
The game runs mostly fine, but if there's any kind of fade between scenes, the sound breaks up irritatingly.
If I lower the refresh rate to something stupid like 5hz, the problem goes away because the emulator only has to draw every so often and the fade is basically unnoticed.

I've tried various combinations of CPU speeds 'n' memory amounts and I mucked about with the JIT compiler options, but I just can't get the thing performing perfectly.
Only thing I haven't tried as yet is to run a different ROM file (at the moment I have one called 'quadra650.rom').

Glitchy sound during fades and transitions is also a problem in Sheepshaver, so - throwing the floor open to anyone who has advice on how to get this stuff running as intended.


IIGS_User's picture
Joined: 2009 Apr 8

I think you've not tried yet another option given by the classic Mac OS:
Increase the game's memory amout by opening its 'Information' window in Finder,
then increase its RAM amount a bit (maybe step by step).

Joined: 2009 Aug 8

I've tried that too, although admittedly I haven't gone overboard - I tried to keep it in portions that might've physically existed (nothing higher than 64MB or whatever).
Should I go ballistic on it and put some big numbers in?

bertyboy's picture
Joined: 2009 Jun 14

Could be the fade draws too much CPU in the emulator, it depends how it's written and then handled by the emulator.
I guess how software usually does it is to manipulate the colour map used for the screen, sliding all colours / shades to black. Maybe this one is different.

Joined: 2009 Aug 8

Indeed. Has anyone else run into this while trying to play Cyberflix games on Basilisk/Sheep Shaver? If it's just a problem with the emulator, then I guess I'll have to live with it (I'm making a walkthrough, my other idea was to just try and capture the video from the mini-VGA of an older computer that runs the game natively).

However, if it's just something wrong with my configuration, then I'd like to sort it out.

Joined: 2011 Jun 13

One tweak I discovered some time ago is to pin Sheepshaver to a specific CPU. On Linux this is done with taskset (CLI), Windows with Taskmanager. Reduced crashes alot.

Joined: 2009 Aug 8

Being on a Mac, I'm not immediately sure of how to do that, but it's an interesting thought, I'll have a poke around.