This page is a wiki. Please login or create an account to begin editing.


4 posts / 0 new
Last post
jonnyboy's picture
Offline
Joined: 2009 Dec 7
Airport card firmware

My issue admittedly more properly belongs on an Ubuntu forum, but there are Mac specific elements.

I have successfully imaged my PowerBook Titanium as a triple boot system (10.4.11, OS 9.2.2, Ubuntu 12.04 LTS/PPC - yes this was a giant pain but I will be happy to field questions about my experience.)

All systems seem to be functioning normal(ish) EXCEPT for one annoying issue; in Ubuntu I cannot connect to my wireless router (...more accurately it seems to connect, timeout, disconnect, repeat ad nauseum...)

Connections from both OS X and OS 9 are both fine and strong, so I know the internal card is OK.

It seems to NOT be WEP/WPA issue - behaviour is the same either method; obviously I prefer WEP for OS 9 access but I have a workaround for this (2nd network, same cable modem) that works just fine.

I am aware of the open-source drivers available in Ubuntu-land, but it would help if I knew the following:

1 - which Broadcom chipset does my Apple Airport Card (PC24-H) have, and/or how do I figure this out?

2 - is it possible to download Airport card firmware SEPARATELY from Airport Router updates in Apple software updates? (or extract, and if so how?)

3 - is it possible to downgrade firmware on an Airport Card? (or do I have to buy them used on eBay until I get an old one...?)

and finally, if you can infer from the above questions that I'm "barking up the wrong tree," what else can I try other than hard-wiring the ethernet cable into my machine every time I boot Ubuntu?

**EDIT**

it would appear that the the correct drivers are probably the Orinoco (not Broadcom)...

http://wireless.kernel.org/en/users/Drivers/orinoco

...but when I tried to install them (or 'make install' as it were) the error message was essentially "only compatible with 2.x.xx kernel" - so it looks like a Wireless USB (or PCI card) is the way to go (...leaning towards something from the Panda wireless family of products)

PLEASE weigh in still - I KNOW I cannot possibly be the only person here to deal with this issue, and I want to hear your solutions - and I still am curious about the answers to question #2 and #3 above.

Comments

Troyd's picture
Offline
Joined: 2014 Nov 14

I only remember that the original Airport cards were rebranded Lucent Wavelan cards, also sold as Orinoco Gold and some details about them exist here http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Linux.Wireless.driv... However, it has been about ten years or so since anyone bothered with this card so all existing coding might be out of date for today's distros.

I do know that a number of Cardbus cards worked in the Titanium under native Airport drivers and gave 802.11g (and with one particular Buffalo card 802.11n) under Tiger. The Belkin F5D7010 (yellow, not silver card) works in my TiBook. You might just pick any cardbus WiFi card that has suitable Linux support.

jonnyboy's picture
Offline
Joined: 2009 Dec 7

currently succeeding with a USB wireless adapter - a friend had a Rosewill RNX-N150HG he wasn't using

themacmeister's picture
Offline
Joined: 2009 Oct 26

brilliant info here

https://wiki.debian.org/orinoco

and

http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Orinoco.html

and

http://ppcluddite.blogspot.com.au/2011/08/wpa-wireless-in-debian-on-g3-i...

Seems to be working up to 3.2.46-1, so should work with latest kernels.

Best of luck!