This page is a wiki. Please login or create an account to begin editing.


7 posts / 0 new
Last post
schavira's picture
Offline
Joined: 2009 Sep 19
After Dark 9 in SheepShaver

I just tried installing After Dark 9 in SheepShaver but it crashes every time it tries to load the extension on the OS 9 startup screen. Does anybody know what is causing this?

Comments

schavira's picture
Offline
Joined: 2009 Sep 19

I tried After Dark 4.0 in Sheepshaver too on 8.6 and it did the exact same thing. This is frustrating me Sad

schavira's picture
Offline
Joined: 2009 Sep 19

It works perfectly fine in Basilisk II running 7.6; this is odd. After Dark Games however crashes on pretty much every attempt to open it no matter what I'm using.

themacmeister's picture
Offline
Joined: 2009 Oct 26

Are you using the specially patched OS9 version? I had this issue with the unpatched 4.0.x control panel. Also, you may want to remove the AfterDark Wallpapers extension (or whatever it is called), as it is unnecessary, and pointless.

It is a shame that FPU screensavers don't run (Satori/Rose). They were great for their day...

bertyboy's picture
Offline
Joined: 2009 Jun 14

The retail After Dark versions work in Mac OS 6 and 7. They stopped working in OS 8 and later.

After Dark for OS9 may work in OS8 and OS9, but again, ONLY if the modules you use have been converted - if they needed it at all.

Edit: Replaced 'xxx 7' with 'Mac OS 7' - IIGS User

schavira's picture
Offline
Joined: 2009 Sep 19

Yeah I was using the After Dark 9 download on this site. In a related story After Dark Games runs for a bit in OS 9 but then crashes when attempting to play certain games (Hula Girl most notably). Some of the other games however work perfectly fine (Rodger Dodger). Am I missing a plugin or should I move one of the extensions from the After Dark Games folder into my system folder? Also it flat out wont run in OS7, but I'm not sure if that has to do with compatibility or anything.

themacmeister's picture
Offline
Joined: 2009 Oct 26

The fix was to decompress some resources, after Apple discontinued that compression scheme in OS9 (and OS8?). I believe adding a software FPU control panel may get the FPU plugins working too.

There is another forum on the internets where they have decompressed *most* of the plugin packs to OS9 format.