This page is a wiki. Please login or create an account to begin editing.


3 posts / 0 new
Last post
Tobibrocki's picture
Offline
Joined: 2015 Apr 6
A-Dock not working after ATI Driver Install?

Hi everyone,

I've been struggling with this problem for a few hours now and have been trying to fix it, and the only other possible solution I can think of would be a reinstall of Mac OS 9.2.2.
But I wanna see if we can figure this out before I have to go there.

So, first a little backstory info, a few days ago I got a PowerMac G3 300Mhz, about 5xxMB of Ram and a ATI Rage 128 Card with 16MB of Ram on it, runs well and nice, so I decided to take the Harddrive from my iMac G3 and put it in the PowerMac, no problems there, boots fine. I then Overclocked the System to 400Mhz, runs stable and bought a ATI Radeon 7000 32MB Mac Edition Card (only PCI Mac Card I could find that didn't cost an arm and a leg) to get a slightly better performance with 3D Games.

Allright, now here is where the trouble begins, I installed the Drivers from the 2005 ATI Driver Update (figured I might aswell go and install the latest I can get), that was a mistake as it turns out.
The System would boot, then switch to 1280x1024 75Hz Resolution (my Monitors native one) and glitch out displaying two small images of the OS9 boot screen and a bunch of glitchiness below it, green numbers and lines etc.
The bootprocess halted on the ATI Extension, thankfully I could still make that out.
So I bootet from the OS9.2.2 CD and removed the Extensions, I then copied the Extensions that I had in the System Folder Backup on my USB Stick over to it and rebootet. I now got into the OS again, but A-Dock was not showing up, apparently it was running though because I didn't get a message to turn it on when I launched the A-Dock Preferences Control Panel.
I thought at that moment, that maybe it would just need a reinstall and instead of focusing on it I installed the Radeon 7000 Mac Edition Drivers that came with the Card, rebootet, worked fine but still no A-Dock. I then installed the 2002 ATI Drivers Update, no Problem again after I rebootet the Computer. Finally I decided to reinstall A-Dock, downloaded it from Macintosh Garden and put the original A-Dock in the Trash, fresh install, reboot, no A-Dock. I tried it several times, booting without the extension and then putting it back in, no effect so far.
I'm kinda stumped on what I could possibly do to fix this.
I don't know if this has perhaps something to do with it, but when the OS Boots, and the Extensions all get loaded in, the "ATI Desktop Accelerator" Extension that has a "Speedy Monitor" kind of Icon shows up Twice and the second one has a red X on it possibly meaning its disabled. This wasn't so before I installed any ATI Software, not sure if this is a possible clue.
The only thing I know of besides reinstalling, is just to copy over the old System Folder from my USB Stick, but that one is a bit old and has a few things missing. =/

Do you guys have any ideas what the problem could be?

Comments

devils_advisor's picture
Offline
Joined: 2012 Jul 9

if it is started and active is it possible that the dock is just out of sight/range? since you had a high resolution before it might be somewhere and you cant see it. i would check the manual if there is a way to grab it or check the prefs file (maybe even trash the prefs).

Tobibrocki's picture
Offline
Joined: 2015 Apr 6

That did it!! Laughing out loud

I first deleted the other "ATI Graphics Accelerator" Extension File (the one that on bootup was marked with a red "X") which the Installer, as it turns out, just moved to a different location instead of overwriting it and didn't disable it unless it was put into the trash. After Rebooting, A-Dock still wasn't accessible/visible so after getting back to the PC and reading your post I did what you said, deleted both A-Dock Prefs and Favourites files and rebooted. BAM, A-Dock is back on Screen, to make extra sure though I rebootet again after putting a few items in it and it's still there. ^^

Thanks for the Help, Devils Advisor! Smile