This page is a wiki. Please login or create an account to begin editing.


4 posts / 0 new
Last post
themacmeister's picture
Offline
Joined: 2009 Oct 26
3TB HDD query - Mac Pro 4,1 AHCI

Now, this isn't a standard question, because I know that Mac OS 10.5+ has supported GPT 3TB HDD partitions since the G5 Power Mac days.

I have a "semi-hacked" Mac Pro 4,1 with patched boot MBR for AHCI support, and up-to-date Intel RST drivers for ICH10R chipset SATA2. I tried removing a USB 3TB HDD and using it internal (Bay 2) and it showed up as a weird arrangement of partitions (none working) starting at 867GB or so. I assume that MBR formatted drives of this size need special partitioning software to work correctly (and a 64bit OS).

It is also obvious that Seagate has the smarts in the circuitry that does the SATA->USB connection, to see all 3TB, even though it is not GPT partitioned?!

I want to use a NEW 3TB HDD as an NTFS formatted GPT partition for storage/archive. I know I can convert to a GPT partition using diskpart, but I fear what this may do to my data (1.5TB already).

If anyone has any experience with 3TB drives, and associated pitfalls and problems, please reply.

Many thanks.

Comments

Protocol 7's picture
Offline
Joined: 2010 Aug 7

In the long run I think you're better going to GPT. Disks that size is one of the reasons for it in the first place.

From my own experience, converting to GPT works. I used the linux gpt tool when I was trying to convert my Windows 7 installation from BIOS to UEFI. Ultimately I ran into problems with booting but that was down to Windows and my EFI partition residing on another disk.

The MBR to GPT conversion worked fine. But I did make a whole disk backup first to be sure.

I'd be wary of partitions showing up in the wrong order in Disk Utility. That happened when I was trying to remove unwanted EFI and MSR partitions on one of my disks. The partitions were displaying wrong in Disk Utility. I deleted the right partition, it deleted the wrong one. Lost over 700GB of data. Which was unrecoverable.

themacmeister's picture
Offline
Joined: 2009 Oct 26

I have windows and Apple EFI on separate disks too... had no end of issues last time (had to reinstall Mac OS X entirely and Win7 entirely, PLUS all the software!!!).

The entire system works right now (using BootChamp or QuickBoot to get into Windows7) and I have a fully working Boot Camp -> Startup Disk under Win7 where I can select either Win7 or OSX permanently.

I am loathe to make dangerous changes, and since my blank 1TB Seagate internal HDD had it's corrupt firmware meltdown a few nights ago (it can NEVER be used again), I have nowhere to do my backups.

I might just stick where I am and see what happens.

themacmeister's picture
Offline
Joined: 2009 Oct 26

A slightly off-topic question.

I ran gptsync (part of rEFIt) and now I have two protective EFI partitions on my single partition OSX boot disk. The boot disk now doesn't show up in Startup Disk prefpane Sad

Is there a non-destructive way to fix this??!!