This page is a wiki. Please login or create an account to begin editing.


RunTime Revolution

Rating:
No votes yet
Category:
Year released:
Author:
Publisher:
#1
[www].se [ftp].se [mirror].us
revolution.sit (12.94 MB)
For Mac OS 8.5 - 8.6 - Mac OS 9
Emulation
Guides on emulating older applications

RunTime Revolution is a HyperCard clone that was previously known as MetaCard and is currently known as LiveCode.

The download file is the latest version of RunTime Revolution for Mac OS 9. Version number is 2.6.1. In the downloads section of the original website, it was labeled both "Revolution Enterprise" and "Revolution Studio".

Development for classic Mac OS halted on the 5th October 2005. The files were completely removed from their website (with add-ons still missing) around September 2010.

Serial: TFRZAXGYFIABDDXAAXOGULVHPJYYLDFKFBVDBWIC
"Name" field can be anything non-empty. "Organization" field can be ignored.

If anyone can find any of the missing add-ons, please do kindly upload them here. They are:
- Animation Engine 3.0 (animationEngine3.zip), "Animation Engine from Derbrill".
- Animation Engine 2.1 (animationengine21.zip), "Animation Engine from Derbrill".
- chartsEngine (chartsEngine_101.zip), "chartsEngine from DerBrill Software. One download for all platforms.".
- Quartam PDF Library 1.0 (qrtpdflib_100_xplatform.zip), "Quartam PDF Library from Quartam Software".
The archived version of the original page hosting these files can be found here: https://web.archive.org/web/20100824044915/http://www.runrev.com:80/down...

For Mac OS X, both PPC and Intel, there's LiveCode: https://downloads.livecode.com/livecode/

Mac OS X versions of RunTime Revolution also do exist (as well as for GNU/Linux and other platforms), which are essentially earlier versions of LiveCode (which continued the version numbering scheme from RunTime Revolution).

Compatibility
Architecture: PPC

- Any PPC Macintosh or clone
- Operating system: Mac OS 8.6 or later
- Memory:
at least 48MB total (128MB total recommended)
at least 20MB free (48MB free recommended)
- Disk space: At least 50MB free
- QuickTime 3.0 or later required for video features (4.1 recommended)
- 1024x768 or larger monitor
- 8-bit (256-color) or higher

Comments

IIGS_User's picture
by IIGS_User - 2019, May 3 - 3:42pm

I don't see CarbonLib as part of of the requirements, but it'd be unusual for 2005 OS 9/8 software not to require it.

This is true, but I think the publisher just didn't mention it in the requirements list.

Jatoba's picture
by Jatoba - 2019, May 2 - 8:34pm

Ah, right, my bad! And indeed, the Read Me made it all clear: Mac OS 8.6 or later. Perhaps SheepShaver is indeed the reason. It couldn't be the absence of the latest version of CarbonLib, could it? I don't see CarbonLib as part of of the requirements, but it'd be unusual for 2005 OS 9/8 software not to require it.

SNakApple's picture
by SNakApple - 2019, May 2 - 7:33pm

I know you are using a Mac Mini Smile (remember the 256 colors at least for your machine). So, there is a "Read me" file which tell the minimum requirements for it. I have tested with Mac OS 8.6 & 9.0.4, but under SheepShaver (probably not the better way!). Sad

Jatoba's picture
by Jatoba - 2019, May 2 - 6:27pm

@SNakApple Hm, strange that you are having that issue. I just tested it on my 9.2.2 machine and it all runs fine. I also used Sherlock to find if I had anything named with "InterfaceLib" in it, and no such file is to be found on any of my drives and partitions. I'm using a Mac mini 1.5 GHz, by the way.

Which Mac OS version did you try it on? By the way, it seems you are right about that it should work on earlier versions of Mac OS: it turns out the website specificially stated it is "for Mac OS 9/Classic and earlier".

Here is the download page I got it from: https://web.archive.org/web/20100824044915/http://www.runrev.com:80/down...

It's probably unrelated to the issue you had, but some files there, stated as being for "All Platforms", weren't archived. So if any of us could find it and put it here, it'd be nice. I believe asking around in LiveCode/RunRev official and unofficial forums might be the best way.
They seem to be extra add-ons:
- Animation Engine 3.0 (animationEngine3.zip), "Animation Engine from Derbrill".
- Animation Engine 2.1 (animationengine21.zip), "Animation Engine from Derbrill".
- chartsEngine (chartsEngine_101.zip), "chartsEngine from DerBrill Software. One download for all platforms.".
- Quartam PDF Library 1.0 (qrtpdflib_100_xplatform.zip), "Quartam PDF Library from Quartam Software".

SNakApple's picture
by SNakApple - 2019, May 2 - 4:45pm

It should works from Mac OS 8.6 to 9.2.2, but unfortunately, I can't get it to run. One file or extension "InterfaceLib..." can't be found, so, may be you already have it in your extension folder or the archive is not complete here ?

Jatoba's picture
by Jatoba - 2019, May 2 - 3:57am

I'm not certain of it, but I suspect this version of RunRev (2.6.1) works specifically with Mac OS 9.2.2, but not any earlier. So if anyone has a Mac OS 9.2.1 or earlier OS 9 Mac to test on, let us know how it goes, in case anyone decides to try it out.