This page is a wiki. Please login or create an account to begin editing.


OpenGL SDK

Rating:
No votes yet
Category:
Year released:
Author:
Publisher:
#1
[www].se [ftp].se [mirror].us
OpenGL_SDK_1.2.img_.bin (42.72 MB)
For Mac OS 8 - 8.1 - Mac OS X
#2
[www].se [ftp].se [mirror].us
OpenGL_CFM_SDK.dmg_.bin (2.45 MB)
For Mac OS 8 - 8.1 - Mac OS X
[www].se [ftp].se [mirror].us
OpenGL_Intro.pdf
Emulation
Guides on emulating older applications

OpenGL SDKs from Apple for building OpenGL applications. Includes headers, libraries, documentation, and sample code/applications.

OpenGL_SDK_1.2.img.bin: OpenGL 1.2 SDK for CFM, released January 2001. OpenGL 1.2 apps can run on Macs from OS 8.1 through OS X. Includes many classic OpenGL GLUT demos.

OpenGL_CFM_SDK.dmg.bin: OpenGL 1.3 SDK for Mac OS X CFM. Only useful for developers building CFM apps to target Mac OS X.

An appropriate version of CodeWarrior (like CodeWarrior Pro 8) is recommended for building apps/samples.

Compatibility
Architecture: PPC PPC (Carbonized)

System Requirements (for running OpenGL apps):
* A PowerPC™ based computer with a minimum of 32 megabytes of memory (RAM)
* Mac OS System 8.1 or newer with the following exception:
Some PowerPC computers with DVD and Mac OS 8.6 software have a set of ATI drivers that are not compatible with the new ATI drivers installed as part of OpenGL 1.2.1; and will cause the DVD software to no longer function correctly. The OpenGL installer will detect these configurations and notify the user that the installation can not proceed until the system has been upgraded to Mac OS 9 or newer. Once you have upgraded to Mac OS 9 or newer, you can install OpenGL 1.2.1 and your DVD software will continue to work as expected.
* QuickDraw3D 1.6 or later