This page is a wiki. Please login or create an account to begin editing.


D Language for OS X

Rating:
No votes yet
Category:
Year released:
Author:
Publisher:
#1
[www].se [ftp].se [mirror].us
gdc-trunk-r229-mac-10.5.dmg (14.43 MB)
For Mac OS X
#2
[www].se [ftp].se [mirror].us
gdc-trunk-r229-mac-10.4.dmg (11.99 MB)
For Mac OS X
#3
[www].se [ftp].se [mirror].us
gdc-0.24-mac-10.4.dmg (11.06 MB)
For Mac OS X
#4
[www].se [ftp].se [mirror].us
gdb-0.2-mac-10.4.dmg (4.61 MB)
For Mac OS X
#5
[www].se [ftp].se [mirror].us
d-textwrangler-lm.zip (1.69 KB)
For Mac OS X
#6
[www].se [ftp].se [mirror].us
d-xcode-support.zip (13.93 KB)
For Mac OS X
#7
[www].se [ftp].se [mirror].us
d-name-demangler.zip (2.97 KB)
For Mac OS X
#8
[www].se [ftp].se [mirror].us
d-for-xcode-1.2.2.zip (174.81 KB)
For Mac OS X
#9
[www].se [ftp].se [mirror].us
LDC_D_Plugin_for_Xcode-1.0.1.zip (128.80 KB)
For Mac OS X
Emulation
Guides on emulating older applications

A variety of utilities for OS X & Xcode that bring the D Language to the platform.

The first four downloads are from the gdcmac project and are command line versions of gdc. The original gdc project (also abandoned) can still be found here.

The fifth file is a syntax module for TextWrangler created by the same developer as the above files.

The sixth & seventh downloads are utilities for Xcode 1.5 (Panther) created by, again, the same developers as the above files. More information about these can be found here.

The eighth download is an Xcode plugin for Xcode 2-3 (Tiger & Leopard) based on DMD. This plugin once had an auto download feature, which would both download & install the DMD suite directly from their website. It, however, is no longer functional as of March 16, 2013. It's home page can still be found here.

The ninth download is yet another Xcode plugin, though this one is based on the LDC compiler. It's home page can be found here.

More information (and modern downloads) for the D language can be found here.

Compatibility
Architecture: PPC x86 (Intel:Mac)

These utilities have ALL been discontinued and are no longer functional on OS X versions beyond Snow Leopard (10.6)

Requires Xcode (and tools) be installed.