This page is a wiki. Please login or create an account to begin editing.


ATI Radeon 9250 Mac OS 9 drivers


Rating:
No votes yet
Category:
Year released:
Author:
Publisher:
#1
[www].se [ftp].se [mirror].us
ATI_9250_OS9.sit_.Bin (1.92 MB)
For Mac OS 9
Emulation
Guides on emulating older applications

I put together a package of the latest ATI extensions modified to get 2D and 3D acceleration in Mac OS 9.2.2 when using a flashed Radeon 9250.

This package will only work with cards with device ID 5960. So you will have to do the resistor mod prior to flashing the card as described here: http://themacelite.wikidot.com/9250-trick

There is supposed to be a modified driver for the 9250 flying around somewhere already but I was not able to get hold of that one so I took a dive into the driver myself and came up with this small fix.
My device ID was already present in most of the driver extension but not in the "ATI Resource Manager".

Compatibility
Architecture: PPC

Comments

supernova777's picture
by supernova777 - 2018, February 21 - 3:36am

R128P RAGE 128 pro 125-145mhz
R100 Radeon 140-185mhz
RV100 Radeon 7000 166-183mhz
R200 Radeon 8500 250-275mhz
RV200 Radeon 7500 260-290mhz
RV250 Radeon 9000 200-275mhz

RV280 Radon 92x0

R300 Radeon 9500/9700 275-310mhz
R350 Radeon 9800 pro 325-380mhz
RV350 Radeon 9600
RV360 Radeon 9600 XT
R360 Radeon 9800 XT
R420 X800 XT 420-500mhz
R480 X850 XT 475-540mhz

TheRealBolle's picture
by TheRealBolle - 2017, May 1 - 4:58pm

The 9600 is not going to work. The 9250 only works because it is using a R2x0 GPU and those chips are supported by the OS 9 drivers ATI made. The 9600 is using R3x0 - like the 9800 - and those are simply not supported by the drivers. Forcing the drivers to load won´t get you anywhere.

SkyCapt's picture
by SkyCapt - 2017, April 28 - 5:44pm

My device ID was already present in most of the driver extension but not in the ATI Resource Manager.

How was this ID editing made? I have an Apple (not flashed) ATI Radeon 9000 which works in OS9 but also an Apple ATI Radeon 9600 which isn't recognized by any OS9 drivers. The 9600 card is twice as fast as the 9000, the 9600 card ID says "0x4150" and I want to force OS9 to recognize it, how?